题目1001:A+B for Matrices

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5

代码如下:

/*------------------------1001----------------------
description:you are supposed to find A+B where A and B are two matrices
                 and then count the number of zero rows and columns.
authour:yuanwei
time     :2013-02-10
--------------------------1001----------------------*/
  
#include <stdio.h>
#include <malloc.h>
#include <string.h>
 
#define M 15
#define N 15
int matrix[M][N] = {0};
 
int main()
{
    int temp = 0;
    int row = 0;
    int col = 0;
    int i = 0;
    int j = 0;
    int counter = 0;//记录当前矩阵和的列数行数为0的总个数
  
    //输入行数和列数
    //不能直接判断scanf函数是否为0调成while循环,所以只能在内部进行判断
    while (scanf("%d", &row) && row)
    {
        scanf("%d", &col);
        //memset(matrix, 0, sizeof(matrix));
        //输入矩阵的值
        for(i = 0; i < row; i++)
        {
            for (j = 0; j < col; j++)
            {
                scanf("%d", &matrix[i][j]);
            }
  
        }
        for(i = 0; i < row; i++)
        {
            for (j = 0; j < col; j++)
            {
                scanf("%d", &temp);
                matrix[i][j] += temp;
            }
        }
  
        for(i = 0; i < row; i++)
        {
            for (j = 0; j < col; j++)
            {
                if (matrix[i][j] != 0)
                {
                    break;
                }
            }
            if (j == col)
            {
                counter++;
            }
  
        }
        for(i = 0; i < col; i++)
        {
            for (j = 0; j < row; j++)
            {
                if (matrix[j][i] != 0)
                {
                    break;
                }
            }
            if (j == row)
            {
                counter++;
            }
  
        }
        printf("%d\n", counter);
  
        //为下次的计数清空
        counter = 0;
    }
      
    return 0;
}
 
/**************************************************************
    Problem: 1001
    User: ruoshui1314
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1020 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值