大整数加法

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 202860    Accepted Submission(s): 38944


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
      
      
2 1 2 112233445566778899 998877665544332211
 

Sample Output
      
      
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
代码
#include<string>
#define MAX_SIZE 1001
#include<cstring>
#include<iostream> 
using namespace std;
int main()
{ 
    int T;
    cin >> T;
    int j = 1;
    while( T-- )
    {
          string  a,b; 
          cin >> a >> b;
          int la =  a.length()-1;
          int lb =  b.length()-1;
          int x[MAX_SIZE],i = 0;
          memset(x,0,sizeof(x));
          for(;(la>=0) && (lb >=0);)
          x[i++] = ((a[la--]-'0') + (b[lb--]-'0'));     
          while((la>=0) )
          x[i++] += (a[la--]-'0');                  
          while((lb>=0) )
          x[i++] += (b[lb--] - '0');                        
          for(int m = 0;m <i ;m++)
          {
              x[m+1]+= (x[m]/10);
              x[m]= x[m]%10; 
          } 
          cout << "Case " << j << ":" << endl;
          cout << a << " + " << b << " = ";
          if(x[i] == 0)
          i-- ;
          for(int m = i;m>=0;m--)
          cout << x[m];
          if(T!=0) 
          cout << endl;
          cout << endl;
          j++;
    }
    system("pause");
    return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值