1001 A+B Format (20 分)[PAT (Advanced Level) Practice]

1001 A+B Format (20 分)

Calculate a + b a+b a+b and output the sum in standard format − − -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ​ ≤ a , b ≤ 1 0 6 −10^6​≤a,b≤10^6 106a,b106​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a a a and b b b in one line. The sum must be written in the standard format.

Sample Input:

1000000 9

Sample Output:

999,991

My code

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char* g(char *a)
{
    int p = strlen(a);
    char *b;
    b = (char*)malloc(sizeof(char)*20);
    
    for (int i=0;i<20;i++){
        b[i] = 0;
    }
    
    for (int i=0;i<p;i++){
        b[p-i-1] = a[i];
    }
    return b;
}
char* f(int c)
{
    char *str;
    str = (char*)malloc(sizeof(char)*20);
    for (int i=0;i<20;i++){
        str[i] = 0;
    }
    int index = 0;
    while(1){
        int tmp = c%10;
        c = c/10;
        str[index] = tmp+'0';
        index++;
        if(c==0)break;
    }
    return g(str);
}

int main(void)
{
    char *re;
    re = (char*)malloc(sizeof(char)*20);
    for (int i=0;i<20;i++){
        re[i] = 0;
    }
    
    int a,b;
    scanf("%d %d",&a, &b);
    int c = a+b;
    int sign=0;
    if (c<0){
        sign=1;
        c = -c;
    }
    
    re = f(c);
    if (sign==1)printf("-");
    int index = 0;
    int q = strlen(re);
    while (re[index]!=0){
        if (index>0 && (q-index)%3==0){
            printf(",");
        }
        printf("%d",re[index]-'0');
        index++;
    }
    free(re);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值