使用pip安装scrapy失败的解决方法

python学习 专栏收录该内容
8 篇文章 0 订阅

使用pip安装scrapy报错:
在这里插入图片描述
解决办法:
需换另一种形式来安装,我们先将scrapy安装过程中所用到的依赖的库安装完成之后,在安装scrapy,这样子便可以安装成功了。
需要安装的依赖库有 lxml、 pyOpenSSL 、 Twisted。需要注意的是我们安装的这些库,都是通过wheel来安装的。因此在安装这些库之前,先得安装wheel。打开控制台窗口,输入pip install wheel,先安装wheel库。

安装这些库的时候,得注意下载的.whl文件的版本号,需要和自身的python的版本号对应。例如
在这里插入图片描述
python的版本3.8 64位,则选择下载的.whl的版本为XXX-cp38-cp38-win-amd64.whl
安装lxml,到https://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted ,查询lxml对应环境python的.whl文件。本文使用的是lxml-4.1.0-cp35-cp35m-win_amd64.whl,下载完成之后。在文件的目录起一个控制台窗口,如下图,便可以启动一个控制台。输入pip install lxml-4.6.1-cp38-cp38-win_amd64.whl,即可安装成功。如果提示版本不对,那么就是python和whl文件的版本不对应。
在这里插入图片描述

安装pyOpenSSL ,直接在控制台输入pip install pyOpenSSL,然后等待安装完成。
安装Twisted,在https://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted,网站上面找到适合的安装whl文件,安装的步骤同安装lxml一样。
都安装好之后,再装scrapy就可以成功了,直接pip install scrapy如果超时下载不成功,可以使用下面两种方式下载:
pip install -i https://pypi.douban.com/simple
pip install -i http://mirrors.aliyun.com/pypi/simple --trusted-host mirrors.aliyun.com
在这里插入图片描述

  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值