POJ1007_DNA Sorting_归并排序求逆序对

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 99293 Accepted: 39899

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

大致题意:

给出m个DNA序列,每个序列有n个碱基。把这m个DNA序列按逆序程度从小到大输出。


大体思路:

这个题做了两遍。

第一遍还是年轻,少不更事,用了一个很朴素的办法,把它当一个水题过了,没啥收获。

第二遍是看了聚聚的题解,用了归并排序的方法求逆序对数。从中初次尝试了归并排序的感觉。

但是有点小问题,第二种思路写出来的程序效率要低于第一种。可能是掌握得不好,写的额比较挫把。


第一种:

#include<iostream>
#include<cstdio>
using namespace std;
char S[105][55],*P[105];
int A[100];
int main()
{
	//freopen("1007.txt","r",stdin);
	int m,n,i,k,j,cnt=0;
	cin>>n>>m;
	for(i=0;i<m;i++){
		cin>>S[i];
		for(k=0;k<n-1;k++)
		for(j=k+1;j<n;j++)
		if(S[i][j]<S[i][k])cnt++;
		A[i]=cnt,cnt=0;
	}
	for(i=0;i<m;i++)
	for(k=0;k<m;k++){
		for(i=0,j=0;i<m;i++)
			if(A[i]>A[j])j=i;
		P[k]=S[j];
		A[j]=-1;
	}
	for(i=m-1;i>=0;i--)cout<<P[i]<<endl;
	return 0;
}


第二种:

#include<cstdio>
#include<algorithm>
#include<cstring>

struct Str
{
	char C[105];
	int cnt;

}S[55];

int len,n;
char M[105],N[105];

bool cmp (Str x,Str y)
{
	return x.cnt<=y.cnt;
}

int Merge (char*S,int s,int m,int e)
{
	int cnt=0;
	int i=s,j=m+1,k=s;
	while(i<=m&&j<=e)
		if(M[i]<=M[j]) N[k++]=M[i++];
		else N[k++]=M[j++],cnt+=(m-i+1);
	while(i<=m) N[k++]=M[i++];
	while(j<=e) N[k++]=M[j++];
	for(i=s;i<=e;i++)
		M[i]=N[i];
	return cnt;
}

int Merge_sort (char*S,int s,int e)
{
	int cnt=0;
	if(s<e){
		int m=(s+e)/2;
		cnt+=Merge_sort(S,s,m);
		cnt+=Merge_sort(S,m+1,e);
		cnt+=Merge(S,s,m,e);
	}
	return cnt;
}


int main()
{
	//freopen("in.txt","r",stdin);

	scanf("%d%d",&len,&n);
	for(int i=0;i<n;i++){
		scanf(" %s",M);
		strcpy(S[i].C,M);
		S[i].cnt=Merge_sort(M,0,len-1);
	}

	std::sort(S,S+n,cmp);

	for(int i=0;i<n;i++)
		printf("%s\n",S[i].C);

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值