POJ2378_Tree Cutting_树状DP

Tree Cutting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4494 Accepted: 2744

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS: 

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

OUTPUT DETAILS: 

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

大致题意:

给出一棵具有N个节点的树结构,要求找出找出这样的节点:把这个节点删除后,被分开的两棵子树的节点数都不大于原树的一半。


大体思路:

树状DP。

合法节点的特点可以抽象为:它之下的最大的子树的节点数不大于原树节点的一半,并且它之下的所有子树的节点和要不小于原树节点和的一半。

维护DP数组记录每个节点之下所有子树的节点总数,状态转移方程为:

dp[i] +=  dp[i+1] + 1 ;

maxson = max ( maxson , dp[i+1]+1 );


#include<cstdio>
#include<cstring>

#define max(x,y) x>y ? x : y
#define limit 10010

int head[limit], pre[limit*2], no[limit*2], tot;//链式前向星的零件
bool vis[limit];//访问过标记
int dp [limit];//子树节点总和(不包含本身)
bool val [limit];//合法标记
int n;

void Insert(int a, int b)//链式前向星的插入函数
{
	no[tot] = b;
	pre[tot] = head[a];
	head[a] = tot;
	tot++;
}

void dfs (int r)//DP函数
{
	vis[r] = 1;//首先把访问标记设置为“真”
	int maxson = 0;//最大子树节点数设置为0
	for(int i=head[r]; i!=-1; i=pre[i]){

		if(vis[no[i]]) continue;//防止回访造成死循环

		dfs(no[i]);//自底向上完成表格填写
		maxson = max(maxson, dp[no[i]]+1);//更新最大子树的节点数
		dp[r] += dp[no[i]]+1;//更新子树节点总数

	}

	if(maxson<=n/2 && dp[r]+1 >= n/2) val[r] = 1;//合法性判断

}

int main ()
{
	//freopen("in.txt","r",stdin);

	memset(head,-1,sizeof(head));//链式前向星头指针表的初始化

	scanf("%d",&n);

	int a, b;
	while(scanf("%d%d",&a,&b) != EOF){
/*******取消边的方向性,
		在这种情况下,可以以任意一个节点为根节点
		代价是增加vis数组防止回访*******/
		Insert(a,b);
		Insert(b,a);
	}

	dfs(1);//DP

	for(int i=1; i<=n; i++)
		if(val[i]) printf("%d\n",i);//输出所有合法节点的标号

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值