POJ3253_Fence Repair_贪心

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45697 Accepted: 14910

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

大致题意:

现有一块木板,要把它分割成指定长度的若干段。每次分割的费用等于分割前这块木板的长度。求分割方案使总费用最小。


贪心,一个有点复杂的贪心。借助了二叉树的思想。

第一次分割,把原木板分成两块小木板,相当于一个父节点派生出两个子节点。这两块小木板可能还要继续分割,又生成了两个子节点。由此就产生了一棵二叉树。总的费用就是整棵树根节点之外的其他节点值之和。因此,最优方案肯定是越小的木板所处的层数越靠下。

知道了最优解的结构,接下来只要从下往上还原原木板就可以了。

建立一个优先队列,每次取出队列中最小的两块木板,加和就是他们的父节点的值,更新答案值,并把这个值加入队列。循环往复直到优先队列中只剩下最后一个元素(整棵树的根节点)。


#include<cstdio>
#include<iostream>
#include<queue>

using namespace std;

int main ()
{
	int N;
	scanf("%d", &N);

	int t;
	priority_queue<long long, vector<long long>, greater<long long> > qu;
	for(int i=1 ;i<=N ;i++){
		scanf("%d", &t);
		qu.push(t);
	}

	long long ans = 0;
	while(qu.size() > 1){

		long long m = qu.top();
		qu.pop();

		long long s = m + qu.top();
		ans += s;
		qu.pop();
		qu.push(s);
	}

	printf("%lld", ans);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值