POJ3268_Silver Cow Party_队列优化的Dijkstra

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21567 Accepted: 9843

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


给定一个点X,求任意一点 前往X的最短路 和 从X返回该点的最短路 的和的最大值。

用dijkstra求两次最短路 求和的最大值 就好了

这个题是第一次用 队列优化的dijkstra


#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#define f(x) x.first
#define s(x) x.second

using namespace std;
typedef pair<int, int> P;

const int maxn = 1010;
int Map [maxn][maxn];
int disf [maxn];
int dist [maxn];
int N, M, X;

void dijkstraf ()
{
	memset(disf, 0x3f, sizeof(disf) );
	priority_queue<P, vector<P>, greater<P> > qu;

	disf[X] = 0;
	qu.push(make_pair(0, X) );

	while(qu.size() ){
		int t = s(qu.top() ), v = f(qu.top() );
		qu.pop();
		if(v > disf[t] ) continue;

		for(int i= 1; i<= N; i++)
			if(disf[i] > disf[t] + Map[t][i]){
				disf[i] = disf[t] + Map[t][i];
				qu.push(make_pair(disf[i], i) );
			}
	}
}

void dijkstrat ()
{
	memset(dist, 0x3f, sizeof(dist) );
	priority_queue<P, vector<P>, greater<P> > qu;

	dist[X] = 0;
	qu.push(make_pair(0, X) );

	while(qu.size() ){
		int t = s(qu.top() ), v = f(qu.top() );
		qu.pop();
		if(v > dist[t] ) continue;

		for(int i= 1; i<= N; i++)
			if(dist[i] > dist[t] + Map[i][t]){
				dist[i] = dist[t] + Map[i][t];
				qu.push(make_pair(dist[i], i) );
			}
	}
}

int main ()
{
	scanf("%d %d %d", &N, &M, &X);

	memset(Map, 0x3f, sizeof(Map) );
	for(int i= 1; i<= N; i++)
		Map[i][i] = 0;

	for(int i= 1; i<= M; i++){
		int s, e, t;
		scanf("%d %d %d", &s, &e, &t);
		if(Map[s][e] > t) Map[s][e] = t;
	}

	dijkstraf();
	dijkstrat();

	int Max = 0;
	for(int i= 1; i<= N; i++){
		int t = disf[i] + dist[i];
		if(Max < t) Max = t;
	}

	printf("%d\n", Max);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值