POJ3169_Layout_spfa && 最短路思想 求 差分约束系统

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11246 Accepted: 5401

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.


本身最短路问题的 三角不等式 就是一个 差分约束系统

因此 差分约束系统 的有关问题可以考虑用最短路的思想 转换成求最短路问题

需要注意的是,最短路对应的是差的最大值


n头牛要进食,有的牛关系好,他们的距离不能大于给出的di,有的牛关系差,他们的距离不能小于给出的di,允许很多牛在同一个点吃。求 第一个头牛 和 最后一头 之间的最大距离。


#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>

using namespace std;

int N, M, D;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
int Map [maxn][maxn];
bool in [maxn];
int times [maxn];
int dis [maxn];

bool spfa ()
{
	queue<int> qu;
	memset(dis, inf, sizeof(dis) );
	memset(in, false, sizeof(in) );
	memset(times, 0, sizeof(times) );

	dis[1] = 0, times[1] = 1, in[1] = true;
	qu.push(1);

	while(qu.size() ){
		int temp = qu.front(); qu.pop();
		in[temp] = false;

		for(int i= 1; i<= N; i++)
		{
			int d = dis[temp] + Map[temp][i];

			if(dis[i] > d)
			{
				dis[i] = d;

				if(!in[i] )
				{
					qu.push(i);
					times[i] ++;
					in[i] = true;

					if(times[i] >= N) return true;
				}

			}

		}
	}

	return false;
}

int main ()
{
	scanf("%d %d %d", &N, &M, &D);

	memset(Map, inf, sizeof(Map) );

	for(int i= 1; i< N; i++)
		Map[i+1][i] = 0;

	for(int i= 1; i<= M; i++){
		int a, b, d;
		scanf("%d %d %d", &a, &b, &d);
		Map[a][b] = d;
	}

	for(int i= 1; i<= D; i++){
		int a, b, d;
		scanf("%d %d %d", &a, &b, &d);
		Map[b][a] = -d;
	}

	if(spfa() ) printf("-1\n");
	else if(dis[N] == inf) printf("-2\n");
	else printf("%d\n", dis[N] );

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值