POJ3734_Blocks_快速幂求解递推问题

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6657 Accepted: 3217

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

给定 N 个方块拍成一列。现在要用红、蓝、绿、黄四种颜色的油漆igei这些方块染色。求染成红色的方块和染成绿色的方块的个数同时为偶数的染色方案的个数,输出对10007取余之后的答案。


递推的思想。

对于 i 个方块,共有三种情况: 两种都是偶数,一种是奇数,两种都是奇数。由此可以转移到 i + 1 个方块的情况。

对于 i + 1 个方块:

两个都是偶数,第一情况下最后一块涂另外两种颜色之一,第二种情况下涂奇数的那种颜色,第三种情况无法转移到本状态。

一个是奇数,第一种情况下最后一块涂这两种颜色之一,第二种情况下涂另外两种颜色之一,第三种情况下涂这两种颜色之一。

都是奇数,第一种情况无法转移到本状态,第二种情况下涂偶数的那种颜色,第三种情况下涂另外两种颜色之一。

根据分析写出转移方程组:

A(i+1) = A(i) * 2 + B(i)

B(i+1) = A(i) * 2 + B(i) * 2 + C(i) * 2

C(i+1) = B(i) + C(i) * 2

进一步将变化表达成矩阵

(2,1,0)(2,2,2)(0,1,2)

然后用矩阵快速幂求第 n 次转移的结果就好了


#include<cstdio>
#include<iostream>
#include<vector>

using namespace std;

typedef vector<int> vec;
typedef vector<vec> mat;

const int mod = 10007;
int T, n;

mat Mul(mat A, mat B)
{
	mat C(A.size(), vec(B[0].size()));

	for(int i= 0; i< A.size(); i++)
		for(int k= 0; k< B.size(); k++)
			for(int j= 0; j< B[0].size(); j++)
				C[i][j] = (C[i][j] + A[i][k] * B[k][j]) % mod;

	return C;
}

mat Pow(mat A, int n)
{
	mat C(A.size(), vec(A.size()));
	for(int i= 0; i< A.size(); i++)
		C[i][i] = 1;

	while(n)
	{
		if(n & 1) C = Mul(C, A);
		A = Mul(A, A);
		n = n >> 1;				//敲黑板
	}

	return C;
}

int main()
{
	mat A(3, vec(3));
	A[0][0] = A[1][0] = A[1][1] = A[1][2] = A[2][2] = 2;
	A[0][1] = A[2][1] = 1;
	A[0][2] = A[2][0] = 0;

	scanf("%d", &T);

	while(T--)
	{
		scanf("%d", &n);

		mat B = Pow(A, n);

		printf("%d\n", B[0][0]);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值