进阶端工程师的前端攻城狮

【Eclipse错误】Syntax error, parameterized types are only available if source level is 1.5

导入一个Java项目报错Syntax error, parameterized types are only available if source level is 1.5

同时找不到swing下的JFrame;JPanel;

问题原因:编译器版本过低
解决方法:将编译器版本提高
eclipse-->"Windows"-->"preferneces"
在弹出对话框中 ,在左侧列表框中 选择 "JAVA" ---子菜单中 "compiler"
然后在右侧把 "Compiler compliance level" 设置成1.5及以上 即可。
阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yuemitengfeng/article/details/46812471
文章标签: eclipse 编译器 错误
上一篇android开发初步——命名规范
下一篇【eclipse】用Eclipse编程时,查看源代码,显示Source not found问题的解决方法。
博主设置当前文章不允许评论。

没有更多推荐了,返回首页

关闭
关闭