大理石在哪儿? where is the marble??(排序和检索)

题意 :现有N个大理石,每个大理石上写了一个非负整数。首先把个个数从小到大排序,然后回答Q个问题。每个问题问是否有一个大理石上写着某个整数x,如果是还要回答那个大理石上写着x。排序后的大理石从左到右编号为1~N。这个题就是简单的排序和检索,然后按要求输出,比较简单,单吗也比较容易懂,如果有不懂的可以随时来问博主哈。

题目链接

题目:

Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.

  Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

  For each of the queries, print one line of output. The format of this line will depend upon whetheror not the query number is written upon any of the marbles. The two different formats are describedbelow:

  • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered1, 2, . . . , N.

  • ‘x not found’, if the marble with number x is not present.

  Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

 

 

解析:题目已经很清楚了,先排序再去找。使用algorithm头文件中的sort函数和lower_bound很容易完成这两部的操作。具体代码如下:

 

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 10000;
int main()
{
    int n,q,x,a[maxn],kase = 0 ;
    while(scanf("%d%d",&n,&q)==2 && n)
    {
        printf("CASE# %d:\n",++kase);
        for(int i = 0 ; i < n ; i ++)
            scanf("%d",&a[i]);
            sort(a,a+n);   // 排序
            while(q--)
            {
                scanf("%d",&x);
                int p = lower_bound(a,a+n,x) - a ;  // 在已经排序的数组a中寻找x
                if(a[p] == x)
                    printf("%d found at %d\n",x,p+1);
                else
                    printf("%d not found\n",x);
            }
    }
    return 0;
}

具体参考刘汝佳大神的算法书。

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值