poj 1201 -Intervals


Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

和刚刚写的poj 1716是一样的,只不过把至少相差两个改成相差c个。。。


代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std ;
#define N 50010
#define INF 1<<30

struct Edge{
    int v, w, next ;
}e[N<<2] ;

int head[N], cnt ;
int l, r ;
bool vis[N];
int s[N], d[N] ;

void init(){
    memset(vis, 0, sizeof(vis)) ;
    memset(head, -1, sizeof(head)) ;
    cnt = 0 ;
}

void add(int u, int v, int w){
    e[cnt].v = v ;
    e[cnt].w = w ;
    e[cnt].next = head[u] ;
    head[u] = cnt++ ;
}

void spfa(){
    for(int i=l; i<r; i++)  d[i] = INF ;
    int h = 0;
    s[h++] = r ;
    d[r] = 0;
    while(h){
        int u = s[--h] ;
        vis[u] = 0 ;
        for(int i=head[u]; i!=-1; i=e[i].next){
            if(d[e[i].v] > d[u] + e[i].w){
                d[e[i].v] = d[u] + e[i].w ;
                if(!vis[e[i].v]){
                    vis[e[i].v] = 1 ;
                    s[h++] = e[i].v ;
                }
            }
        }
    }
}

int main(){
    int n ;
    while(scanf("%d", &n) == 1){
        init() ;
        l = 50000, r = 0 ;
        for(int i=1; i<=n; i++){
            int a, b, c;
            scanf("%d %d %d", &a, &b, &c) ;
            add(++b, a, -c) ;
            r = max(r, b + 1) ;
            l = min(l, a) ;
        }
        for(int i=l; i<r; i++){
            add(i, i+1, 1) ;
            add(i+1, i, 0) ;
        }
        spfa() ;
        printf("%d\n", d[r] - d[l]) ;
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值