hdu 1025

 

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11068    Accepted Submission(s): 3162


Problem Description

 

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.  

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.  

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.  

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 


 

Input

 

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 


 

Output

 

For each test case, output the result in the form of sample.  
You should tell JGShining what's the maximal number of road(s) can be built.  
 


 

Sample Input

 

  
  
2 1 2 2 1 3 1 2 2 3 3 1
 


 

Sample Output

 

  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
 


 

 

 

昨天在组队赛里做了一道需要用n*logn的算法,实现在序列中找到最长升序子序列;

所以,之后又在hdu上找了一道类似的题目,练一练手~

 

这道题,将穷的城市的点作为序列中的下标,富的城市的点作为序列中的数,求的即是最长升序子序列,只是因为n比较大,用n*n的算法太慢,所以要优化成nlogn的算法

这里主要是要维护一个数组,dp[ i ]  表示升序列为i的序列中,最后一个元素的最小值;这样一来,以top记做当前最长的升序子序列的长度,那么对初始的序列:

 

if(a[i]>dp[top])

      dp[top++]=a[i]

else{

      dp[erfen(a[i])]=a[i]

}

查找出的是当前序列中,最后一个元素小于a[i] 的序列长度的最大值。

 

代码:

 

#include<stdio.h> 
#include<iostream>
using namespace std;
int a[500005],dp[500005]; 
int top; 
int binary_search(int x) 
{ 
    int l=0,r=top,mid; 
    while(l<=r) 
    { 
        mid=(l+r)>>1; 
        if(dp[mid]>=x) r=mid-1; 
        else
        { 
            l=mid; 
            if(dp[l+1]>=x)return l+1; 
            else l++; 
        } 
    } 
}  
int main() 
{ 
    int n,i; 
    int times=0;
    while(scanf("%d",&n)==1) 
    { 
        times++;
        for(i=0;i<n;i++){
            int temp1,temp2; 
            scanf("%d%d",&temp1,&temp2);
            a[temp1]=temp2;
        } 
        top=0;dp[0]=a[1]; 
        for(i=2;i<=n;i++) 
        { 
            if(a[i]>dp[top]) dp[++top]=a[i]; 
            else
            { 
                if(a[i]<=dp[0]) dp[0]=a[i];
                else  dp[binary_search(a[i])]=a[i]; 
            } 
        } 
        cout<<"Case "<<times<<":"<<endl;
       cout<<"My king, at most "<<top+1<<" road";
       if(top!=0)
          cout<<"s";
       cout<<" can be built."<<endl; 
       cout<<endl;
    } 
    return 0; 
} 


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值