poj 3630(phone list)

Phone List
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23670 Accepted: 7276

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

 
 
 
这道题目考查的是Trie树的应用。
Trie树一种高效的查询树结构,集查询与插入在一起,基本相同。
在这题目中,有两种情况。
(1) 短的号码在前,长的在后面
 在读取长号码的时候,若其前缀是其他的号码的时候,就可以直接 return false;后面就不需要再比较了;
(2)长的号码在前面。
 在查询(插入)过程中,查询结束后,如发现是前缀,则return false;
 
 
代码如下( 浏览器是ie8 以下,用不了编辑器~~,难看了点)
#include <iostream>
#include <memory.h>
using namespace std;
int nodenum,flag;
struct tree_node
{
   bool isstr;
   tree_node *branch[10];
}Node[100100];
class Trie
{
private:
   tree_node root;
public:
   Trie() { root=Node[0];}
   bool insert(char *word)
   {
      tree_node *location=&root;
      int i=0,len=strlen(word);
      while(word[i])
      {
          if(i==len-1&&location->branch[word[i]-'0']!=NULL)
              return false;
          if(location->branch[word[i]-'0']==NULL)  //创建新的结点
          {
              location->branch[word[i]-'0']=&Node[nodenum];
              Node[nodenum].isstr=false;
              memset(Node[nodenum].branch,0,sizeof(Node[nodenum].branch));
              nodenum++;
          }
          if(location->branch[word[i]-'0']->isstr)
              return false;
          location=location->branch[word[i]-'0'];
          i++;
      }
      location->isstr=true;
      return true;
     }
};
int main()
{
  int t,n;
  cin>>t;
  while(t--)
  {
     cin>>n;
     flag=true;
     nodenum=1;
     char tel[11];
     Trie t;
     while(n--)
     {
         cin>>tel;
         if(!t.insert(tel) )
               flag=false;
     }
    if(flag)
       cout<<"YES"<<endl;
    else
       cout<<"NO"<<endl;
   }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值