hdu1006 Tick and Tick (时钟问题)

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14396    Accepted Submission(s): 3279


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

Sample Input
  
  
0 120 90 -1
 

Sample Output
  
  
100.000 0.000 6.251
 

Author
PAN, Minghao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1007  1008  1010  1009  1011 
 

解析:这道题,其实想通了也不难,甚至可以说太简单了。
           时钟的时针、分针、秒针一天内的三次重合点:0:00  12:00   24:00
           所以计算这道题的是时候,只需要考虑0:00到12:00即可。

            设:ws     表示秒针的角速度
                   wm    表示分针的角速度
                   wh     表示时针的角速度
                
                  wsm=ws-wm   表示秒针相对于分针的角速度 
                  wsh=ws-wh     表示秒针相对于时针的角速度
                  wmh=wm-wh   表示分针相对于时针的角速度
                  
            那么就有:(t1,t2,t3<=12*60*60)

                  360*(i-1)+d<=wsm*t1<=360*i-d
                  360*(j-1)+d<=wsh*t2<=360*j-d
                  360*(k-1)+d<=wmh*t3<=360*k-d
                
            t1、t2、t3可取时间的交集即为答案。
           
           具体实现如下:
              用 sum 来记录happy time,以秒为单位。

             1.枚举 i ,得到 t1  与 i 对应的左右界:L、R
                若 L>=12*60*60 退出循环。              

             2.枚举 j ,得到 t2  与 j 对应的左右界:L2、R2。
                此时应满足[L2,R2]∩[L,R] ≠ 空集。

             3.枚举 k ,得到t3 与 k 对应的左右界:L3、R3
                 此时应满足[L3,R3]∩[L2,R2] ≠ 空集,则 [L3,R3]能使上述三个不等式均成立,为happy time。
                 sum+=R3-L3。
代码:
#include<cstdio>
#include<cmath>
using namespace std;

double sum,d,wsm,wsh,wmh;

int main()
{
  freopen("1.in","r",stdin);
  wsm=59/10.0,wsh=719/120.0,wmh=11/120.0;
  double l,r,l2,r2,l3,r3;
  int i,j,k;
  while(scanf("%lf",&d),d>-0.5)
    {
      for(sum=0,i=1;;i++)
        {
          l=(360*i-360+d)/wsm;
          r=(360*i-d)/wsm;
          if(l>12*60*60)break;
            
          j=(int)((l*wsh+d)/360);
		  if((360*j-d)/wsh<=l)j++;  
		  for(;;j++)
		    {
		      l2=(360*j-360+d)/wsh;
			  r2=(360*j-d)/wsh;
			  if(l2<l)l2=l;
			  if(r2>r)r2=r;
			  if(l2>=r2)break;
			  
			  k=(int)((l2*wmh+d)/360);
			  if((360*k-d)/wmh<=l2)k++;
			  for(;;k++)
			    {
			      l3=(360*k-360+d)/wmh;
			      r3=(360*k-d)/wmh;
			      if(l3<l2)l3=l2;
			      if(r3>r2)r3=r2;
			      if(l3>=r3)break;
			      sum+=r3-l3;
			    } 
		    }
        }
      printf("%.3lf\n",sum/(12*60*60)*100);  
    }
  return 0;
}


                 

  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值