hdu5228 ZCC loves straight flush(模拟)

ZCC loves straight flush

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 611    Accepted Submission(s): 266


Problem Description
After losing all his chips when playing Texas Hold'em with Fsygd on the way to ZJOI2015, ZCC has just learned a black technology. Now ZCC is able to change all cards as he wants during the game. ZCC wants to get a Straight Flush by changing as few cards as possible. 

We call a five-card hand a Straight Flush when all five cards are consecutive and of the same suit. You are given a five-card hand. Please tell ZCC how many cards must be changed so as to get a Straight Flush.
  
Cards are represented by a letter('A', 'B', 'C', 'D') which denotes the suit and a number('1', '2',  , '13') which denotes the rank.
  
Note that number '1' represents ace which is the largest actually. "1 2 3 4 5" and "10 11 12 13 1" are both considered to be consecutive while "11 12 13 1 2" is not.
 

Input
First line contains a single integer  T(T=1000)  which denotes the number of test cases.
For each test case, there are five short strings which denote the cards in a single line. It's guaranteed that all five cards are different.
 

Output
For each test case, output a single line which is the answer.
 

Sample Input
  
  
3 A1 A2 A3 A4 A5 A1 A2 A3 A4 C5 A9 A10 C11 C12 C13
 

Sample Output
  
  
0 1 2
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5231  5230  5229  5227  5226 
 

  解析:模拟。直接暴力枚举所有的胜利情况,然后一一匹配,得到匹配牌数x,需要改变的牌就为5-x。
             需要注意的是,5招牌并不一定是有序的,也就是说:A1 A2 A5 A4 A3 也是同花顺。一开始没注意到这个,调试一下午都没找出来。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 10
using namespace std;

int a[maxn],b[maxn];
char s[maxn];

void work()
{
  int i,j,k,p,q,sum,ans,x,y;
  for(i=1;i<=5;i++)
    {
      scanf("%s",s);
      a[i]=s[0]-'A';
      b[i]=s[1]-'0';
      k=strlen(s);
      for(j=2;j<k;j++)b[i]=b[i]*10+s[j]-'0';
    }
  
  ans=5;
  for(i=0;i<4;i++)
    for(j=1;j<=10;j++)
      {
        sum=0,x=i,y=j;
        for(k=0;k<5;k++)
          {
            if(y==14)y=1;
            for(p=1;p<=5;p++)
              if(a[p]==x && b[p]==y)sum++;
            y++;  
          }
        ans=min(ans,5-sum);  
      }
  printf("%d\n",ans);	  
}

int main()
{
  freopen("1.in","r",stdin);
  int t,i,j,k;
  while(scanf("%d",&t)!=EOF)
    for(i=1;i<=t;i++)work();
  return 0; 
}

    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值