BestCoder Round #60 GT and numbers (模拟)

GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 133    Accepted Submission(s): 39


Problem Description
You are given two numbers  N  and  M .

Every step you can get a new  N  in the way that multiply  N  by a factor of  N .

Work out how many steps can  N  be equal to  M  at least.

If N can't be to M forever,print  1 .
 

Input
In the first line there is a number  T . T  is the test number.

In the next  T  lines there are two numbers  N  and  M .

T1000 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
  
  
3 1 1 1 2 2 4
 

Sample Output
  
  
0 -1 1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5508  5507  5506  5503  5502 
 


解析:n要变成m,即可表示为:n*(m/n)==m

           以n=2  m=32为例演示这个转换过程:

                 n=2  m/n=16

                1.  n=n*gcd(n,m/n)=4

                2.  n=n*gcd(n,m/n)=16

                3.  n=n*gcd(n,m/n)=32

          其实就是一直重复 n=n*gcd(n,m/n) 这个过程,直到n==m。        

代码:

#include<cstdio>
#include<iostream>
using namespace std;

typedef unsigned long long ull;
ull n,m;

ull gcd(ull x,ull y)
{
  ull t;
  while(y!=0)t=x%y,x=y,y=t;
  return x;
}

void work()
{
  if(n==m)
    {
      cout<<0<<endl;
      return;
	}
  if(n==1 || m%n)
    {
      cout<<-1<<endl;
      return;
	}
	
  ull ans=0,k; m=m/n;
  while(m>1)
    {
      k=gcd(n,m);
      if(k==1)
	    {
	      cout<<-1<<endl;
	      return;
	    }
      n*=k,m/=k,ans++;
	}
  cout<<ans<<endl;
}

int main()
{
  freopen("2.in","r",stdin);
  int t;
  cin>>t;
  while(t--)
    {
	  cin>>n>>m;
	  work();
    }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值