zoj3497 Mistwald (矩阵快速幂+图论)

Mistwald

Time Limit: 2 Seconds       Memory Limit: 65536 KB

In chapter 4 of the game Trails in the Sky SC, Estelle Bright and her friends are crossing Mistwald to meet their final enemy, Lucciola.

Mistwald is a mysterious place. It consists of M * N scenes, named Scene (1, 1) to Scene (MN). Estelle Bright and her friends are initially at Scene (1, 1), the entering scene. They should leave Mistwald from Scene (MN), the exiting scene. Note that once they reach the exiting scene, they leave Mistwald and cannot come back. A scene in Mistwald has four exits, north, west, south, and east ones. These exits are controlled by Lucciola. They may not lead to adjacent scenes. However, an exit can and must lead to one scene in Mistwald.

Estelle Bright and her friends walk very fast. It only takes them 1 second to cross an exit, leaving a scene and entering a new scene. Other time such as staying and resting can be ignored. It is obvious that the quicker they leave Mistwald, the better.

Now you are competing with your roommate for who uses less time to leave Mistwald. Your roommate says that he only uses P seconds. It is known that he lies from time to time. Thus, you may want to code and find out whether it is a lie.

Input

There are multiple test cases. The first line of input is an integer T ≈ 10 indicating the number of test cases.

Each test case begins with a line of two integers M and N (1 ≤ MN ≤ 5), separated by a single space, indicating the size of Mistwald. In the next M lines, the ith line contains Npieces of scene information, separated by spaces, describing Scene (i, 1) to Scene (iN). A scene description has the form "((x1,y1),(x2,y2),(x3,y3),(x4,y4))" (1 ≤ xk ≤ M; 1 ≤ yk ≤ N; 1 ≤ k ≤ 4) indicating the locations of new scenes the four exits lead to. The following line contains an integer Q (1 ≤ Q ≤ 100). In the next Q lines, each line contains an integer P (0 ≤P ≤ 100,000,000), which is the time your roommate tells you.

Test cases are separated by a blank line.

Output

For each P, output one of the following strings in one line: "True" if it cannot be a lie; "Maybe" if it can be a lie; "False" if it must be a lie.

Print a blank line after each case.

Sample Input
2
3 2
((3,1),(3,2),(1,2),(2,1)) ((3,1),(3,1),(3,1),(3,1))
((2,1),(2,1),(2,1),(2,2)) ((3,2),(3,2),(3,2),(3,2))
((3,1),(3,1),(3,1),(3,1)) ((3,2),(3,2),(3,2),(1,1))
3
1
2
10

2 1
((2,1),(2,1),(2,1),(2,1))
((2,1),(2,1),(2,1),(2,1))
2
1
2
Sample Output
Maybe
False
Maybe

True
False


Author:  WU, Jun
Contest:  The 8th Zhejiang Provincial Collegiate Programming Contest


解析:(先贴着代码,抽空补)

代码:

#include<cstdio>
#include<cctype>
#include<cstring>
using namespace std;

int n;

int read()
{
  int ans=0;char tmp;
  while(!isdigit(tmp=getchar()));
  do ans=(ans<<3)+(ans<<1)+tmp-'0';
  while(isdigit(tmp=getchar()));
  return ans;
}

void multi(bool (*x)[25],bool (*y)[25])
{
  int i,j,k;
  bool c[25][25]={0};
  for(i=0;i<n;i++)
    for(j=0;j<n;j++)
      for(k=0;k<n;k++)
        c[i][j]|=x[i][k]*y[k][j];
  for(i=0;i<n;i++)
    for(j=0;j<n;j++)
      x[i][j]=c[i][j];
}

int main()
{
  //freopen("1.in","r",stdin);
  
  int i,j,k,m,t,x,y,q,p;
  bool st[25][25],a[25][25],b[25][25];
  for(scanf("%d",&t);t;t--)
    {
      m=read(),n=read();
      memset(st,0,sizeof(st));
      for(i=0;i<m;i++)
        for(j=0;j<n;j++)
          {
            k=n*i+j; 
            
            x=read()-1,y=read()-1;
            if(k!=n*m-1)st[k][n*x+y]=1;

            x=read()-1,y=read()-1;
            if(k!=n*m-1)st[k][n*x+y]=1;

            x=read()-1,y=read()-1;
            if(k!=n*m-1)st[k][n*x+y]=1;

            x=read()-1,y=read()-1;
            if(k!=n*m-1)st[k][n*x+y]=1;
		  }
	  for(n=n*m,q=read();q;q--)
	    {
	      for(i=0;i<n;i++)
	        for(j=0;j<n;j++)
	          a[i][j]=st[i][j],b[i][j]=(i==j);
	    
		  for(p=read();p;multi(a,a),p>>=1)
		    if(p&1)multi(b,a);
	      if(!b[0][n-1]){printf("False\n");continue;}
	      for(i=0;i<n-1;i++)if(b[0][i])break;
	      printf("%s\n",(i<n-1)?"Maybe":"True");
		}
	  printf("\n");
	}
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值