HDOJ 1250 Hat's Fibonacci

1.Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6559    Accepted Submission(s): 2178


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 2.源码

#include <stdio.h>
#include <string.h>
int main()
{
	int i=1,j,n,jin,m,s;
	int a[5][260];//只用五行做空间,选一行为当前计算行。
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		a[1][0]=a[2][0]=a[3][0]=a[4][0]=1;
		for(i=5;i<=n;i++)
		{
			jin=0;
			m=i%5;
			for(j=0;j<260;j++)
			{
				s=a[0][j]+a[1][j]+a[2][j]+a[3][j]+a[4][j]+jin-a[m][j];
				jin=s/100000000;//不是按照10位进位,而是按照8位一进位。
				a[m][j]=s%100000000;
			}
		}
		i=259;
		while(!a[n%5][i])
		   i--;
		printf("%d",a[n%5][i]);//头8位可能不足8位提前输出。
		i--;
		while(i>=0)
		{
			printf("%08d",a[n%5][i]);
			i--;
		}
		printf("\n");//注意别忘了换行.
	}
	return 0;
}


根据看到两个代码综合一下,感觉还不错。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值