hdu杭电 2141 Can you find it? 【二分 N*logN】

6 篇文章 0 订阅
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 



//ac代码

//Can you find it

#include<cstdio>
#include<algorithm>
using namespace std;
int s[550*550];
int main()

{
	int m,n,l;//表示abc 
	int t,x;
	int i,k,j;
	int mid;
	int a[550],b[550],c[550];
	int num=0;
	while(~scanf("%d%d%d",&m,&n,&l))
	{
		for(i=0;i<m;++i)
		{
			scanf("%d",a+i);
		}
		for(i=0;i<n;++i)
		{
			scanf("%d",b+i);
		}
		for(i=0;i<l;++i)
		{
			scanf("%d",c+i);
		}
		int p=0;
		for(j=0;j<n;++j)//把b集合和c集合的数存到s数组中
		{
			for(k=0;k<l;++k)
			{
				s[p++]=b[j]+c[k];
			}
		}
		sort(s,s+p);//排序
		printf("Case %d:\n",++num);
		scanf("%d",&t);
		while(t--)
		{
			int flag=0;
			scanf("%d",&x);
			for(i=0;i<m;++i)
			{
				int l,r;
				if(s[0]+a[i]==x||s[p-1]+a[i]==x)
				{
					flag=1;
					break;
				}
				/*else if(s[0]+a[i]>x || s[p-1]+a[i]<x)
				{					
					continue;
				}*/																			
				l=0;r=p-1;
				while(r>=l)
				{
					mid=(l+r)/2;
					if(s[mid]+a[i]==x)
					{
						flag=1;
						break;
					}
					else if(s[mid]+a[i]<x)  l=mid+1;
					else if(s[mid]+a[i]>x)  r=mid-1;						
				}									
				if(flag) break;							
			}
			if(flag) printf("YES\n");
			else printf("NO\n");
		}
	} 
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值