Be the Winner HDU杭电2509 【尼姆博弈】

http://acm.hdu.edu.cn/showproblem.php?pid=2509


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
  
  
2 2 2 1 3
 

Sample Output
  
  
No Yes
 
//这里用到博弈的知识

http://baike.baidu.com/link?url=o1BeXSvZyGiVosS_HwR7dvB5vDrroHL2aJNp9SmwxNpet_dPwtDCp8Th3QRmo03gp-WY8znVaFBnCCjC1iHHba

#include <stdio.h>
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int flag=1;//判断是否全为一
		int sum=0,temp;
		for(int i=0;i<n;++i)
		{
			scanf("%d",&temp);
			sum^=temp;//判断是否为必输状态
			if(temp>1) flag=0;
		}
		if(flag==1)
		{
			if(n&1)
			{
				printf("No\n");
			}
			else printf("Yes\n");
		}
		else
		{
			if(sum==0) printf("No\n");
			else printf("Yes\n");
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值