本身这道题可以用DFS来实现,但为了学习使用next_permutation函数,因此本文中不用DFS
在说这道题目之前,我先介绍一下next_permutation函数的使用方法
/*
bool next_permutation(iterator start, iterator end);
包含在头文件#include<algorithm>中
全排列的函数,函数中的两个参数是迭代器,返回的值是bool类型,
作用是将一个序列进行一次排列,排成比原序列大一个字典序的序列,并返回true
如果没有比原序列字典序更大的序列,那么将返回false
*/
//备注:如果想要得到所有的排列,需起始序列的字典序最小,否则要进行升序排序(可以使用sort函数)
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
char a[10]="abcd";
int main()
{
int len=strlen(a);
do
{
for(int i=0;i<len;i++)
{
cout<<a[i]<<" ";
}
cout<<endl;
}while(next_permutation(a,a+len));
return 0;
}
接下来以南阳OJ的19题为例进一步使用这个函数
擅长排列的小明
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
4
-
描述
- 小明十分聪明,而且十分擅长排列计算。比如给小明一个数字5,他能立刻给出1-5按字典序的全排列,如果你想为难他,在这5个数字中选出几个数字让他继续全排列,那么你就错了,他同样的很擅长。现在需要你写一个程序来验证擅长排列的小明到底对不对。
-
输入
-
第一行输入整数N(1<N<10)表示多少组测试数据,
每组测试数据第一行两个整数 n m (1<n<9,0<m<=n)
输出
- 在1-n中选取m个字符进行全排列,按字典序全部输出,每种排列占一行,每组数据间不需分界。如样例 样例输入
-
2 3 1 4 2
样例输出
-
1 2 3 12 13 14 21 23 24 31 32 34 41 42 43
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int main()
{
string str="123456789";
int N;
cin>>N;
while(N--)
{
int n,m;
cin>>n>>m;
string str1=str.substr(0,n);
string str2=str1.substr(0,m);
cout<<str2<<endl;
while(next_permutation(str1.begin(),str1.end()))
{
string str3=str1.substr(0,m);
if(str2==str3)
continue;
else
{
cout<<str3<<endl;
str2=str3;
}
}
}
return 0;
}
时间用的会比DFS长,但代码长度会变短,也更容易理解。如果条件允许的话,不妨使用这个函数