HDU 3652 B-number 数位dp

B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6350 Accepted Submission(s): 3678

Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output
Print each answer in a single line.

Sample Input
13
100
200
1000

Sample Output
1
1
2
2

题目大意:求不大于n的数中有多少个数既有13,又能被13整除。

不难看出这是一道数位dp,如果去掉被13整除这个条件,就是很裸的数位dp入门题,记忆化搜索即可。
但如果加上13这个条件后还像原来三维转移肯定是有bug的,比如13这个数,它是满足条件的,但113显然不满足,不过如果像原来那样转移就会认为113也是满足条件的。
考虑再加一维,表示对13取余后的结果。
f[i][j][k][z] i表示位数 j表示前一位数 k表示取mod z表示是否包含13
每次推到下一位的时候重新算一下模数就好。
也算一道板吧。
update:10.5

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

const int N = 15;

int a[N];
int dp[N][N][2][N];

int dfs(int pos,int pre,int mod,int statue,bool zero,bool limit){
    if(pos<=0) return (mod==0)&&statue;
    if(!limit&&!zero&&dp[pos][pre][statue][mod]!=-1) return dp[pos][pre][statue][mod];
    int mx;if(limit) mx=a[pos];
    else mx=9;
    int ans=0;
    for(int i=0;i<=mx;i++){
        ans+=dfs(pos-1,i,(mod*10%13+i%13)%13,statue||(pre==1&&i==3),zero&&i==0,limit&&i==mx);
        //mod * 10 我之前是怎么想的 pre*10啊 
    }
    if(!limit) dp[pos][pre][statue][mod]=ans;
    return ans;
}

int query(int x){
    int cnt=0;
    while(x){
        a[++cnt]=x%10;
        x/=10;
    }
    ms(dp,-1);
    return dfs(cnt,0,0,0,1,1);
}

int main(){
    int n;;
    while(~scanf("%d",&n)){
       printf("%d\n",query(n));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值