POJ 1070 Fibonacci 矩阵乘法

Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16414 Accepted: 11513

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

Stanford Local 2006

第一次打矩阵快速幂。
矩阵题意已经给了2333(大概题面即题解),所以裸的矩阵快速幂。
还是特别喜欢自己的板。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn = 2;
const int mod = 1e4;

struct Matrix{
    int mat[maxn][maxn];
    void unit(){
        for(int i=0;i<maxn;i++)
           for(int j=0;j<maxn;j++)
              mat[i][j]=(i==j);
    }

    void zero(){
        for(int i=0;i<maxn;i++)
           for(int j=0;j<maxn;j++)
              mat[i][j]=0;
    }
};

Matrix operator *(Matrix a,Matrix b){
   Matrix c;c.zero();
   for(int k=0;k<maxn;k++)
     for(int i=0;i<maxn;i++)
      for(int j=0;j<maxn;j++)
        c.mat[i][j]=(c.mat[i][j]+a.mat[i][k]*b.mat[k][j])%mod;
    return c;
}

Matrix mpow(Matrix a,int b){
    Matrix rt;
    for(rt.unit();b;b>>=1,a=a*a)
        if(b&1) rt=rt*a;
    return rt;
}

int main(){
    int n;Matrix temp;
    for(int i=0;i<maxn;i++)
       for(int j=0;j<maxn;j++)
         temp.mat[i][j]=1;
    temp.mat[1][1]=0;//构建矩阵 
    while(1){
        scanf("%d",&n);
        if(n==-1) break;
        Matrix a=mpow(temp,n);
        printf("%d\n",a.mat[0][1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值