bzoj 1688: [Usaco2005 Open]Disease Manangement 疾病管理 状压

5 篇文章 0 订阅

1688: [Usaco2005 Open]Disease Manangement 疾病管理

Time Limit: 5 Sec Memory Limit: 64 MB
Submit: 742 Solved: 473
[Submit][Status][Discuss]

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible. If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

Input

  • Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first integer, d_i, is the count of cow i’s diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

Output

  • Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2

0———第一头牛患0种病

1 1——第二头牛患一种病,为第一种病.

1 2

1 3

2 2 1

2 2 1

Sample Output

5

OUTPUT DETAILS:

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two

diseases (#1 and #2), which is no greater than K (2).

HINT

Source

Silver

题解:状压。
最开始迷之读错题。数组开两维的话会MLE[血与泪的教训[虽然我算下来应该是可以的啊qaq。一维要注意从大到小滚动,否则可能用当前更新过的再去更新。

也就写写状压的傻逼题了吧T_T

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

const int M = 1<<15;
const int N = 1000 + 5;

int d,n,k;
int num[M],mp[N];
int dp[M];

int lowbit(int x){
    return x&(-x);
}

int count(int x){
    int cnt=0;
    while(x){
        ++cnt;
        x&=(x-1);
    }
    return cnt;
}

inline int Max(int a,int b) {return a>b?a:b;}

int main(){
    scanf("%d%d%d",&n,&d,&k);
    for(int i=1;i<=n;i++){
        int x;scanf("%d",&x);
        while(x--){
            int xd;scanf("%d",&xd);
            mp[i]+=1<<xd-1;
        }
    }
    int tot=(1<<d)-1;
    for(int i=0;i<=tot;++i) num[i]=count(i);
    for(int i=1;i<=n;++i){
      for(int j=tot;j>=0;--j){
        int d=mp[i]|j;
        dp[d]=Max(dp[d],dp[j]+1);
      }
    }
    int ans=0;
    for(int i=0;i<=tot;i++)
        if(num[i]<=k) ans=Max(ans,dp[i]);
    cout<<ans<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值