HDU 3849 Recognizing These Guys, We Find Social Networks Useful

Recognizing These Guys, We Find Social Networks Useful

Description

Social Network is popular these days.The Network helps us know about those guys who we are following intensely and makes us keep up our pace with the trend of modern times.
But how?
By what method can we know the infomation we wanna?In some websites,maybe Renren,based on social network,we mostly get the infomation by some relations with those “popular leaders”.It seems that they know every lately news and are always online.They are alway publishing breaking news and by our relations with them we are informed of “almost everything”.
(Aha,”almost everything”,what an impulsive society!)
Now,it’s time to know what our problem is.We want to know which are the key relations make us related with other ones in the social network.
Well,what is the so-called key relation?
It means if the relation is cancelled or does not exist anymore,we will permanently lose the relations with some guys in the social network.Apparently,we don’t wanna lose relations with those guys.We must know which are these key relations so that we can maintain these relations better.
We will give you a relation description map and you should find the key relations in it.
We all know that the relation bewteen two guys is mutual,because this relation description map doesn’t describe the relations in twitter or google+.For example,in the situation of this problem,if I know you,you know me,too.

Input

The input is a relation description map.
In the first line,an integer t,represents the number of cases(t <= 5).
In the second line,an integer n,represents the number of guys(1 <= n <= 10000) and an integer m,represents the number of relations between those guys(0 <= m <= 100000).
From the second to the (m + 1)the line,in each line,there are two strings A and B(1 <= length[a],length[b] <= 15,assuming that only lowercase letters exist).
We guanrantee that in the relation description map,no one has relations with himself(herself),and there won’t be identical relations(namely,if “aaa bbb” has already exists in one line,in the following lines,there won’t be any more “aaa bbb” or “bbb aaa”).
We won’t guarantee that all these guys have relations with each other(no matter directly or indirectly),so of course,maybe there are no key relations in the relation description map.

Output

In the first line,output an integer n,represents the number of key relations in the relation description map.
From the second line to the (n + 1)th line,output these key relations according to the order and format of the input.

Sample Input

1
4 4
saerdna aswmtjdsj
aswmtjdsj mabodx
mabodx biribiri
aswmtjdsj biribiri

Sample Output

1
saerdna aswmtjdsj

题意:给你一张无向图,判断桥边的数量,按照题目输入顺序输出桥边。

题解:
对于一条边的两个节点u,v,如果dfn[u]< low[v]或者dfn[v]< low[u],则这条边是一个桥。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<map>
#include<string>
using namespace std;

inline int read(){
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9') {if(ch=='-') f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') {x=x*10+ch-'0';ch=getchar();}
    return x*f;
}

const int N = 10000 + 10;
const int M = 100000 + 10;

int n,m;
struct node{
    int pre,u,v;
}e[M<<1];

int num=1,head[N];
void addedge(int from,int to){
    e[++num].pre=head[from],e[num].v=to;
    head[from]=num,e[num].u=from;
}

int fa[N];
int indx=0,dfn[N],low[N];
int cnt=0,bridge[N];
void tarjan(int u,int f){
    dfn[u]=low[u]=++indx;
    for(int i=head[u];i;i=e[i].pre){
        int v=e[i].v;
        if(!dfn[v]){
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u]) bridge[++cnt]=i;
        }
        else if(f!=v) low[u]=min(low[u],dfn[v]);
    }
}

int find(int x){
    if(x==fa[x]) return fa[x];
    return fa[x]=find(fa[x]);
}

#define ms(x,y) memset(x,y,sizeof(x))
void update(){
    num=1;ms(head,0);indx=0;
    ms(dfn,0);ms(low,0);cnt=0;
    for(int i=1;i<=n;++i) fa[i]=i;
}

string s1,s2;

int main(){
    int t=read();
    while(t--){
        n=read(),m=read();int tot=0;
        update();
        map<int,string> mp;
        map<string,int> mmp;
        for(int i=1;i<=m;++i){
            cin>>s1>>s2;
            if(!mmp[s1]) {mmp[s1]=++tot;mp[tot]=s1;}
            if(!mmp[s2]) {mmp[s2]=++tot;mp[tot]=s2;}
            int u=mmp[s1],v=mmp[s2];
            addedge(u,v);addedge(v,u);
            int x=find(u),y=find(v);
            if(x==y) continue;
            fa[x]=y;
        }
        int f=find(1),flag=false;
        for(int i=2;i<=n;++i){
            if(find(i)!=f){
                flag=true;
                break;
            }
        }
        if(flag) {printf("0\n");continue;}
        tarjan(1,0);
        printf("%d\n",cnt);
        sort(bridge+1,bridge+1+cnt);
        for(int j=1;j<=cnt;++j){
            int i=bridge[j];
            if(i&1) i=i^1;
            cout<<mp[e[i].u]<<' '<<mp[e[i].v]<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值