PAT1049. Counting Ones (30)数1问题

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5
总感觉在哪里见过这个题目。。

看了博客发现好像是个面试题,于是乎,来发博客了。

首先观察样例:12 中有1的数为1,10,11,12. 个位是1的数有两个 1,11,十位为1的数有3个10,11,12.  总和即为2+3=5 个。推广一下,答案就是每一位数字为1的个数之和。

遍历每一位数字,每次把数分成三部分,当前位置的数,当前数的高位,当前数的低位。 例如: 2134 当前位为3时,高位为21,低位为4.

如果当前的数字为0,0后面的数不会影响当前位1的个数,所以只加上 高位×权重  比如100 = 10×1+1×10+2

如果当前的数字为1,和低位有关,加上 (高位×权重 )+(低位+1)

如果当前的数字大于1,同样与低位无关,但要累加到高位上。 所以加上 (左边的数+1)×权重

具体还是看代码吧。。。

#include<bits/stdc++.h>

using namespace std;

int Count(int n)
{
    int ans=0;
    int base=1;
    while(n/base!=0)
    {
        int r=n%base;
        int l=n/(base*10);
        int now=(n/base)%10;
        if(now==0)ans+=l*base;
        else if(now==1)ans+=l*base+r+1;
        else ans+=(l+1)*base;
        base*=10;
    }
    return ans;
}

int main()
{
    int n;
    scanf("%d",&n);
    int ans=Count(n);
    printf("%d\n",ans);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值