PAT 1046. Shortest Distance (20)

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10

7

自己的代码。思路就是sum2=sum-sum1。然而每次直接一项一项加求sum1会超时。在上次的sum1基础上处理成现在的sum1。

#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;

long int a[100001];

  int main()
{
     long int n;
     cin>>n;
     long int sum=0;
     for(long int i=1;i<=n;i++)
        {scanf("%ld",&a[i]);
           sum+=a[i];
        }
      long int m;
      cin>>m;
      long int xx,yy;
      long int x,y;
      long int sum1=0,sum2=0;
      scanf("%ld %ld",&x,&y);
      if(x>y){
            long int tmp=x;
            x=y;
            y=tmp;
          }
          long int gg;
       for(long int i=x;i<y;i++)
             sum1+=a[i];
             sum2=sum-sum1;
             gg=sum1>sum2?sum2:sum1;
          printf("%ld\n",gg);
          xx=x;yy=y;
      for(long int i=1;i<m;i++)
      {

          scanf("%ld %ld",&x,&y);
          if(x>y){
            long int tmp=x;
            x=y;
            y=tmp;
          }
          if(x!=xx)
          {
              if(x>xx)
                 for(long int j=xx;j!=x;j++)
                   sum1-=a[j];
              else
               for(long int j=x;j!=xx;j++)
                 sum1+=a[j];
          }

          if(y!=yy)
          {
              if(y>yy)
                 for(long int j=yy;j!=y;j++)
                   sum1+=a[j];
              else
               for(long int j=y;j!=yy;j++)
                 sum1-=a[j];
          }
             sum2=sum-sum1;
             gg=sum1>sum2?sum2:sum1;
             xx=x;yy=y;
          printf("%ld\n",gg);
      }



       return 0;
}


然后看了下别人代码,更简单,本质是利用HASH的思想,将所有1到i的距离都提前存起来。到时候减一减就好

#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;

long int a[100001]={0}; //  a[i]表示从1号节点到i+1号的距离

  int main()
{
     long int n;
     cin>>n;
     long int tmp=0;
     for(long int i=1;i<=n;i++)
        {scanf("%ld",&tmp);
           a[i]=a[i-1]+tmp;
        }
      long int m;
      cin>>m;
      for(long int i=0;i<m;i++)
      {
            long int x,y;
          scanf("%ld %ld",&x,&y);
          if(x>y){
            long int tmp=x;
            x=y;
            y=tmp;
          }
          long int zz=a[y-1]-a[x-1];
        zz=min(zz,a[n]-zz);
          printf("%ld\n",zz);
      }



       return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值