PAT 1082. Read Number in Chinese (25)

1082. Read Number in Chinese (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:

yi Shi Wan ling ba Bai


哇。这小破题规则贼繁琐。关键在于0的处理。


#include <iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<string.h>
#include<string>
#include<vector>
using namespace std;

int main()
{
   string a;
   cin>>a;
   int flag=0;
   int kg=0;
   if(a.size()==1)
   {
      if(a[0]=='0')
       {cout<<"ling";return 0;}
   }
   if(a.size()==2)
   {
       if(a[0]=='-'&&a[1]=='0')
         {cout<<"ling";return 0;}
    //    if(a[0]=='-')

   }
    char path[15];
   int p=0;
   if(a[0]=='-') {cout<<"Fu";flag=1;kg=1;}
   {
       for(int i=a.size()-1;i>=flag;i--)
          path[p++]=a[i];
       char last=0;

       for(int i=p-1;i>=0;i--)
      {
          int tmp=path[i]-'0';
          switch(tmp)
          {
              case 0:if(kg==1&&last!=0) {cout<<' ';kg=1;cout<<"ling";}break;
              case 1:if(kg==1) cout<<' ';kg=1;cout<<"yi";break;
              case 2:if(kg==1) cout<<' ';kg=1;cout<<"er";break;
              case 3:if(kg==1) cout<<' ';kg=1;cout<<"san";break;
              case 4:if(kg==1) cout<<' ';kg=1;cout<<"si";break;
              case 5:if(kg==1) cout<<' ';kg=1;cout<<"wu";break;
              case 6:if(kg==1) cout<<' ';kg=1;cout<<"liu";break;
              case 7:if(kg==1) cout<<' ';kg=1;cout<<"qi";break;
              case 8:if(kg==1) cout<<' ';kg=1;cout<<"ba";break;
              case 9:if(kg==1) cout<<' ';kg=1;cout<<"jiu";break;
          }
          if(tmp)
          switch(i)
            {
                case 1:if(kg==1) cout<<' ';kg=1;cout<<"Shi";
                if(path[0]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
                case 2:if(kg==1) cout<<' ';kg=1;cout<<"Bai";
                if(path[1]=='0'&&path[0]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
                case 3:if(kg==1) cout<<' ';kg=1;cout<<"Qian";
                if(path[2]=='0'&&path[1]=='0'&&path[0]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
              //  case 4:if(kg==1) cout<<' ';kg=1;cout<<"Wan";break;
                case 5:if(kg==1) cout<<' ';kg=1;cout<<"Shi";
                if(path[4]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
                case 6:if(kg==1) cout<<' ';kg=1;cout<<"Bai";
                if(path[5]=='0'&&path[4]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
                case 7:if(kg==1) cout<<' ';kg=1;cout<<"Qian";
                  if(path[6]=='0'&&path[5]=='0'&&path[4]=='0')
                  {
                      last=0;goto tutu;
                  }
                    break;
              //  case 8:if(kg==1) cout<<' ';kg=1;cout<<"Yi";break;
                case 9:if(kg==1) cout<<' ';kg=1;cout<<"Shi";
                  if(path[8]=='0')
                  {
                      last=0;goto tutu;
                  }
                break;
            }
           last=tmp;
           tutu:
               if(i==4) {cout<<" Wan";last=999;}
           if(i==8) {cout<<" Yi";last=999;}
       }



   }




   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值