PAT 1104. Sum of Number Segments (20) double要在int型前面!未解之谜

1104. Sum of Number Segments (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 
Sample Output:
5.00
 
 
很蛋疼的一道题。坑点在于数据溢出。
 
 
#include <iostream>
#include<stdio.h>
#include<string>
#include<queue>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#include<math.h>
using namespace std;

double num[100000]={0};

int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    cin>>num[i];
    double sum=num[0];
    for(int i=1;i<=n;i++)
    {
        sum+=num[i]*i*(n+1-i);    //num[]一定要放最前面!!!
    }
   

     printf("%.2lf",sum);
    //system("pause");
  return 0;
}

我用动态规划做的只能过三个,不知道为什么
#include <iostream>
#include<stdio.h>
#include<string>
#include<queue>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#include<math.h>
using namespace std;

double num[100002]={0};
double dp[100002]={0};
long long cnt[100002]={0};
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    cin>>num[i];
    dp[0]=num[0];      //以i为结尾的串的和
    cnt[0]=1;          //以i为结尾的串的数量
    double sum=num[0];
    for(int i=1;i<n;i++)
    {
      dp[i]=num[i]*cnt[i-1]+dp[i-1];
        cnt[i]=cnt[i-1]+1;
        dp[i]+=num[i];
      sum+=dp[i];
    }
        printf("%.2lf",sum);
    //system("pause");
  return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值