图论:HDU-1213 How Many Tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题意:

一个人邀请了很多朋友来吃晚餐。他想知道一共需要准备多少张桌子。并不是所有的朋友都认识对方,而且所有的朋友都不愿意和陌生人待在一起。如果A认识B,B认识C。这代表A,B,C三人互相认识,所以他们可以在一张桌子上。如果A认识B,B认识C,D认识E。则A,B,C可以在一张桌子上。而D和E只能在另一张桌子上。

也就是要求连通分支的数目。哈哈,没有规定每张桌子最多坐多少人。

求出一共有多少根节点就可以了(fa[x]==-1)。

#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 1010
int fa[maxn];

int find(int x)
{
	if(fa[x]==-1)
	return x;
	return fa[x]=find(fa[x]);
}

void mix(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	fa[fx]=fy;
}

int main()
{
	int n,m,x,y;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(fa,-1,sizeof(fa));
		scanf("%d%d",&n,&m);
		while(m--)
		{
			scanf("%d %d",&x,&y);
			mix(x,y);
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			if(fa[i]==-1)
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值