2020NYIST个人积分赛第四场-F

题目

原题链接 HihoCoder - 1032

就是最长回文子串

Sample Input
3
abababa
aaaabaa
acacdas

Sample Output
7
5
3

思路

以某个位置为中心位置,向两边扩展判断是否是回文串,再判断是否为最长回文串(注意边界处理)

代码

#include <algorithm>
#include <cmath>
#include <cstdio>
#include <iomanip>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#define pi 3.14159265
using namespace std;
//map<string, int> rr;
int len;
char st[20202020];
int main()
{
	int n;
	cin >> n;
	while(n--)
	{
		int s, e, l, maxe = 0;
		st[0] = 1;//边界处理  让左边不等于右边界
		cin >> st+1;//整个字符串向后移一位  从1开始存
		int len = strlen(st);
		for (int i = 1; i < len;i++)
		{
			s = e = i;
			while(st[i]==st[e+1])
			{
				e++;
			}
			i = e;
			while(st[s-1]==st[e+1])
			{
				s--;
				e++;
			}
			l = e - s + 1;
			if(l>maxe)
				maxe = l;
		}
		cout << maxe << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值