//杭电ACM - 1048
The Hardest Problem Ever
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11958 Accepted Submission(s): 5400
Problem Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:
Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U
Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.
A single data set has 3 components:
Start line - A single line, "START"
Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar
End line - A single line, "END"
Following the final data set will be a single line, "ENDOFINPUT".
Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.
Sample Input
START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
Source
South Central USA 2002
My code
#include <iostream>
using namespace std;
int main()
{
int i,j;
string line = "a",line2 = "a";
char c;
while( getline(cin,line) ){ //排错:读取第一行字符串,赋给word。如果读取失败,退出循环。
if(line == "ENDOFINPUT") return 0; //排错:如果新的一组开头是“ENDOFINPUT”,return 0,程序结束。此时word值为“ENDOFINPUT”。
else if(line == "START"){ //正确:如果新的一组开头是“START”,继续检测。此时word值为“START”
while( getline(cin,line) ){
if( line == "END" ) break; //如果遇到“END”,退出循环。
else { //为要翻译的语句
line2=line;
for(i=0;line[i]!='\0';i++){ //循环到这一句最后。
if( 'A'<=line[i] && line[i]<='E' )
line2[i]=line[i]+21;
else if( 'F'<=line[i] && line[i]<='Z' )
line2[i]=line[i]-5;
}
}
cout<<line2<<endl;
}
}
else return 0; //排错:如果输入既不是START也不是ENDOFINPUT,说明有错,return0程序结束。
}
return 0;
}
算法分析:
主要运用到getline()函数,读取每一行的字符串。
gets(buf);
cin.getline( buf, 255 );