D.类的继承与派生

该博客介绍了面向对象编程中类的继承与派生概念,通过一个具体的球形零件制造问题展示如何利用继承计算产品重量和造价。示例中定义了一个Sphere基类和Product派生类,派生类继承了基类的属性并扩展了计算体积、重量和造价的方法。在main函数中,读取半径、密度和价格输入,然后创建Product对象并输出相关信息。
摘要由CSDN通过智能技术生成
D.类的继承与派生
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 26 (17 users)Total Accepted: 17 (17 users)Special Judge: No
Description
某工厂需要打造某种球形零件,在尝试的过程中使用了不同的金属,要求根据产品的尺寸信息和所用金属的密度信息以及金属的单位价格计算产品的重量及造价。

Input
本题只有一组测试数据,测试数据由3个浮点型数组成,数据之间用空格分隔。格式如下:
半径 密度 金属价格
注:半径单位为m,密度单位为kg/m3,金属价格单位为元/kg。

Output
输出包含四行,格式如下:
Radius:半径
Volume:体积
Weight:重量
Cost:造价

Sample Input
5 1 2

Sample Output
Radius:5
Volume:523.333
Weight:523.333
Cost:1046.67

Hint
class Sphere{
private:
    double radius;
public:
    Sphere(double r);
    double getArea();
    double getVol();
    void show();
};


int main()
{
    double radius,density,price;
    cin>>radius>>density>>price;
    Product product(radius,density,price);
    product.show();
}

#include<iostream>
#include<string>
#include<cmath>
using namespace std;

class Sphere {
private:
    double radius;
public:
    Sphere() {};
    Sphere(double r)
    {
        radius = r;
    }
    double getR() { return radius; };
    double getVol()
    {
        double a = 1.33 * 3.14 * pow(radius, 3);
        return a;
    }
};

class Product :public Sphere
{
public:
    double radius,density, price;
    Product(double r,double d,double p)
    {
        radius=r, density = d, price = p;
    }
    void show()
    {
        cout << "Radius:" <<radius << endl;
        cout << "Volume:" << 4 * 3.14 * pow(radius, 3)/3 << endl;
        cout << "Weight:" << 4 * 3.14 * pow(radius, 3)/3 * density << endl;
        cout << "Cost:" << 4 * 3.14 * pow(radius, 3)/3 * density * price << endl;
    }
};

int main()
{
    double radius, density, price;
    cin >> radius >> density >> price;
    Product product(radius, density, price);
    product.show();
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值