Repeating Decimals

Repeating Decimals

The decimal expansion of the fraction 1/33 is 0
:
03, where the
03 is used to indicate that the cycle 03
repeats inde nitely with no intervening digits. In fact, the decimal expansion of every rational number
(fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no
such repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below.
Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
fraction
decimal expansion
repeating cycle
cycle length
1/6
0.1(6)
6
1
5/7
0.(714285)
714285
6
1/250
0.004(0)
0
1
300/31
9.(677419354838709)
677419354838709
15
655/990
0.6(61)
61
2
Write a program that reads numerators and denominators of fractions and determines their repeating
cycles.
For the purposes of this problem, de ne a repeating cycle of a fraction to be the rst minimal length
string of digits to the right of the decimal that repeats inde nitely with no intervening digits. Thus
for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0
which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).
Input
Each line of the input le consists of an integer numerator, which is nonnegative, followed by an integer
denominator, which is positive. None of the input integers exceeds 3000. End-of- le indicates the end
of input.
Output
For each line of input, print the fraction, its decimal expansion through the rst occurrence of the cycle
to the right of the decimal or 50 decimal places (whichever comes rst), and the length of the entire
repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the
entire repeating cycle does not occur within the rst 50 places, place a left parenthesis where the cycle
begins | it will begin within the rst 50 places | and place `
…)
’ after the 50th digit.
Sample Input
76 25
5 43
1 397
Sample Output
76/25 = 3.04(0)
1 = number of digits in repeating cycle
5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle
1/397 = 0.(00251889168765743073047858942065491183879093198992…)
99 = number of digits in repeating cycle

#include <stdio.h>
#include <string.h>

int main(){
    int a[3010],b[3010],c[3010];
    int m,n;
    while(~scanf("%d%d",&n,&m)){
        int t=n;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        int x=0;
        a[x++]=n/m;
        n%=m;
        while(b[n]==0&&n){
            b[n]=x;
            c[x]=n;
            a[x++]=10*n/m;
            n=10*n%m;
        }
        printf("%d/%d = %d.",t,m,a[0]);
        for (int i=1;i<x&&i<=50;i++){
            if (n&&c[i]==n){
                printf("(");
            }
            printf("%d",a[i]);
        }
        if (n==0){
            printf("(0");
        }
        if (x>50){
            printf("...");
        }
        printf(")\n");
        printf("   ");
        if(n){
            printf("%d",x-b[n]);
        }
        else{
            printf("1");
        }
        printf(" = number of digits in repeating cycle\n\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值