Return of the Nim

Return of the Nim
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

Sherlock and Watson are playing the following modified version of Nim game:

There are n piles of stones denoted as ,,...,, and n is a prime number;
Sherlock always plays first, and Watson and he move in alternating turns. During each turn, the current player must perform either of the following two kinds of moves:
    Choose one pile and remove k(k >0) stones from it;
    Remove k stones from all piles, where 1≤k≤the size of the smallest pile. This move becomes unavailable if any pile is empty.
Each player moves optimally, meaning they will not make a move that causes them to lose if there are still any better or winning moves.

Giving the initial situation of each game, you are required to figure out who will be the winner
Input

The first contains an integer, g, denoting the number of games. The 2×g subsequent lines describe each game over two lines:
1. The first line contains a prime integer, n, denoting the number of piles.
2. The second line contains n space-separated integers describing the respective values of ,,…,.

1≤g≤15
2≤n≤30, where n is a prime.
1≤pilesi≤ where 0≤i≤n−1

Output

For each game, print the name of the winner on a new line (i.e., either “Sherlock” or “Watson”)
Example Input

2
3
2 3 2
2
2 1

Example Output

Sherlock
Watson

Think:比赛的时候发现这个题是博弈的题,于是就怼了半个多小时,只博弈出来第一组数据,第二组数据死活没博弈出来,于是就放弃了,等比完赛听别人一说才发现是分情况用nim博弈和威佐夫博弈,以前做的博弈题都是一种博弈方法,哎

 #include <stdio.h>
 #include <math.h>
 int main(){
    int t,n,a[110],sum;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for (int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        if (n>=3){
            sum=a[0];
            for (int i=1;i<n;i++){
                sum^=a[i];
            }
            if (sum==0)
            printf("Watson\n");
            else
            printf("Sherlock\n");
        }
        if (n==2){
            if (a[0]<a[1]){
                int tt=a[0];
                a[0]=a[1];
                a[1]=tt;
            }
            int x=(int)(a[0]-a[1])*((sqrt(5.0)+1.0)/(2.0));
            if (x==a[1])
            printf("Watson\n");
            else
            printf("Sherlock\n");
        }
    }
    return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值