A.Bus to Udayland

题目:ZS the Coder and Chris the Baboon are travelling to Udayland! To get there, they have to get on the special IOI bus. The IOI bus has n rows of seats. There are 4 seats in each row, and the seats are separated into pairs by a walkway. When ZS and Chris came, some places in the bus was already occupied.

ZS and Chris are good friends. They insist to get a pair of neighbouring empty seats. Two seats are considered neighbouring if they are in the same row and in the same pair. Given the configuration of the bus, can you help ZS and Chris determine where they should sit?
输入:The first line of the input contains a single integer n (1 ≤ n ≤ 1000) — the number of rows of seats in the bus.

Then, n lines follow. Each line contains exactly 5 characters, the first two of them denote the first pair of seats in the row, the third character denotes the walkway (it always equals ‘|’) and the last two of them denote the second pair of seats in the row.

Each character, except the walkway, equals to ‘O’ or to ‘X’. ‘O’ denotes an empty seat, ‘X’ denotes an occupied seat. See the sample cases for more details.
输出:If it is possible for Chris and ZS to sit at neighbouring empty seats, print “YES” (without quotes) in the first line. In the next n lines print the bus configuration, where the characters in the pair of seats for Chris and ZS is changed with characters ‘+’. Thus the configuration should differ from the input one by exactly two charaters (they should be equal to ‘O’ in the input and to ‘+’ in the output).

If there is no pair of seats for Chris and ZS, print “NO” (without quotes) in a single line.

If there are multiple solutions, you may print any of them.
题目大意:车上座位有n排,每一排四个座位,中间被走道隔开。求是否有两个座位是相邻且是空位。若有,则输出YES并将空位用“+”代替空位输出座位表;若没有,则输出NO。
样例输入:
OO|OX
XO|XX
OX|OO
XX|OX
OO|OO
OO|XX
样例输出:
YES
++|OX
XO|XX
OX|OO
XX|OX
OO|OO
OO|XX
样例输入:
4
XO|OX
XO|XX
OX|OX
XX|OX
样例输出:
NO
注意:
Note that the following is an incorrect configuration for the first sample case because the seats must be in the same pair.
大意:被走道隔开是不算相邻的
题解:啊这题好傻逼啊毕竟是cf的A题。。。
所以这题没什么思路啊
模拟啊=。=

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cmath>
#include <string>
#include <string.h>
#include <numeric>
#include <queue>
#include <vector>
#define REM main
using namespace std;
int REM()
{
    int n;
    cin.sync_with_stdio(false);
    scanf("%d",&n);

    int ansi;
    bool k=0;
    char a[1001][5];
    for (int i=1;i<=n;i++)
      {
        scanf("%s",a[i]);
        if ((a[i][0]==a[i][1] && a[i][0]=='O') || (a[i][3]==a[i][4] && a[i][3]=='O'))
            k=1,ansi=i;
      }
    if (k)
      {
        printf("YES\n");
        for (int i=1;i<=n;i++)
          {
            if (i==ansi) 
              {
                if (a[i][0]==a[i][1] && a[i][0]=='O')
                  cout<<"++"<<a[i][2]<<a[i][3]<<a[i][4];
                else
                  cout<<a[i][0]<<a[i][1]<<a[i][2]<<"++";
              }
            else
              for (int j=0;j<=4;j++) cout<<a[i][j];
            cout<<"\n";
          }
      }
    else
      printf("NO\n");
    return 0;
}

=。=唉本人水平弱,只好这么天梯式地往上面爬。。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值