HDOJ 2896 AC自动机

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15901    Accepted Submission(s): 4056


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
  
  
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
  
  
web 1: 1 2 3 total: 1
 
AC自动机模板题,然而坑了我很多遍,首先是要可见的ASCII码,把MAX跳到95,然后都减去32,。还有就是输出病毒的时候要升序输出。
#include<iostream>
#include<stdio.h>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#define MAX 95
using namespace std;
struct node{
       node *fail,*s[MAX];
       int w;
}*head;
int t,n,i,j,sum;
char temp[205],str[10005];
queue<node*> myqueue;
node *getfail(node *p,int k){
     if (p->s[k]!=NULL) return p->s[k];
     else
          if (p==head) return head;
          else return getfail(p->fail,k);
}
void built_trie(int key){
     node *root=head;
     node *tep;
     for (j=0;j<strlen(temp);j++){
         if (root->s[temp[j]-32]==NULL){
            tep=new node;
            for (int k=0;k<MAX;k++)
                tep->s[k]=NULL;
            tep->w=0;
            tep->fail=head;
            root->s[temp[j]-32]=tep;
            }

         root=root->s[temp[j]-32];
         if (j==strlen(temp)-1) root->w=key;
         }
     return ;
}
void built_ac(){
     node *root;
     while (!myqueue.empty()) myqueue.pop();
     myqueue.push(head);
     while (!myqueue.empty()){//构造fail指针用BFS的方法扩展
           root=myqueue.front();
           myqueue.pop();
           for (j=0;j<MAX;j++)
               if (root->s[j]!=NULL){
                  myqueue.push(root->s[j]);
                  if (root==head) root->s[j]->fail=head;
                  else root->s[j]->fail=getfail(root->fail,j);
                  }
           }
     return ;
}
vector<int>find(){
     int len=strlen(str);
     node* tep;
     vector<int>v;
     node *root=head;
     for (j=0;j<len;j++){
         while (root->s[str[j]-32]==NULL && root!=head) root=root->fail;
         root=(root->s[str[j]-32]==NULL)?head:root->s[str[j]-32];
         tep=root;
         while (tep!=head){//如果单词A出现过了,那么与他具有相同前缀的单词也都出现过了
               if(tep->w!=0)
                    v.push_back(tep->w);
               tep=tep->fail;
               }
         }
     return v;
}
int main(){

    scanf("%d",&n);
        int cnt=1;
          head=new node;
          for (i=0;i<MAX;i++)
              head->s[i]=NULL;
          head->fail=head;
          head->w=0;
    while(n--)
    {
          scanf("%s",temp);
          built_trie(cnt++);
    }
    built_ac();
    scanf("%d",&n);
   cnt=0;
    sum=0;
    while(n--)
    {
        scanf("%s",str);
        vector<int>v=find();
        cnt++;
        if(v.size()){
            sum++;
            printf("web %d:",cnt);
            sort(v.begin(),v.end());
            for(int i=0;i<v.size();i++)
                cout<<" "<<v[i];
            cout<<endl;
        }

    }
       printf("total: %d\n",sum);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值