【ACM菜逼解题报告】Age Sort

Age Sort

You are given the ages (in years) of all people of a country with at least 1 year of age. You know that no individual in that country lives for 100 or more years. Now, you are given a very simple task of sorting all the ages in ascending order.


Input
There are multiple test cases in the input file. Each case starts with an integer n (0 < n ≤ 2000000), the total number of people. In the next line, there are n integers indicating the ages. Input is terminated with a case where n = 0. This case should not be processed.

Output
For each case, print a line with n space separated integers. These integers are the ages of that country sorted in ascending order.
Warning: Input Data is pretty big (∼ 25 MB) so use faster IO.

Sample Input
5
3 4 2 1 5
5
2 3 2 3 1
0

Sample Output
1 2 3 4 5
1 2 2 3 3


此题由于N的取值范围在1~2000000之间,所以无法使用快速排序,由于年龄的取值范围在1~99之间,范围很小,所以使用计数排序是能够承受的。


附代码如下:

#include<cstdio>
#include<cstring>

using namespace std;

#define clr(x) (memset(x,0,sizeof(x)))

int age[100];

int main(){
	int n,x;
	while(scanf("%d",&n)==1&&n){
		clr(age);
		int flag=true;
		for(int i=0;i<n;i++){
			scanf("%d",&x);
			age[x]++;
		}
		for(int i=1;i<100;i++){
			if(age[i])
				while(age[i]--){
					if(flag){
						printf("%d",i);
						flag=false;
					}else printf(" %d",i);
				}
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值