POJ 1113 Wall 凸包求周长

Wall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26286 Accepted: 8760

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了

题目大意:

      有一个贪心的国王,他要你的朋友帮他围着他的城堡砌墙,然而他要求你的墙总是隔他的城堡L的距离,并且要求你使用的墙面长度(周长)最小,不然就砍了你朋友。输入给出N个点的坐标构成这个城堡,给出距离L。

解题思路:

      大家可以动手画一画给出的样例(很快就画完了)。发现当点 i 和 i+1 和 i+2 是一条直线的时候,也就是两条线段中间不转弯的情况下,我们的周长直接加线段长就好了。但是如果中间出现了转交,那么有两种情况。让我们看看下面的图:


从图中可以看出,如果出现了这样的两个角,那么还不如我们直接砌直线。所以我们可以得出我们构造的最短周长,应该是构造一个凸包。我们的周长就是所有的直线长度加上转角的特殊弧长。弧长怎么算呢?细心一点就知道每个转角对应的圆心角应该是π-内角(我们作城堡直线路径的垂线看看!)。

      由此我们再加上这些弧长就是我们的答案了!

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
#define eps 10e-9
#define MAX 1002

struct Point 
{
    double x,y;
    Point() {}
    Point ( double x , double y  ) : x(x) , y(y) {}
};
typedef Point Vector;
Point operator - ( Point a , Point b ) { return Point ( a.x - b.x , a.y - b.y ); }

bool cmp ( Point a, Point b ) 
{
    if ( a.x != b.x ) return a.x < b.x;
    else return a.y < b.y;
}

double Length ( Vector v )
{
    return sqrt ( v.x * v.x + v.y * v.y );
}

double Dot ( Vector u , Vector v )
{
    return u.x * v.x + u.y * v.y;
}

int dcmp ( double x )
{
    if ( fabs ( x ) < eps ) return 0;
    else return x < 0 ? -1 : 1 ;
}

double Distance ( Point a , Point b )
{
    return sqrt ( ( a.x - b.x ) * ( a.x - b.x ) + ( a.y - b.y ) * ( a.y - b.y ) );
}

double Cross ( Vector u , Vector v )
{
    return u.x * v.y - u.y * v.x;
}

double Angle ( Vector u , Vector v ) { return acos ( Dot ( u , v ) / Length ( u ) / Length ( v ) ); }

int ConvexHull ( Point *p , int n , Point *ch )  //求凸包
{
    int m = 0;
    sort ( p , p + n , cmp );
    for ( int i = 0 ; i < n ; i ++ )
    {
        while ( m > 1 && Cross ( ch[m-1] - ch[m-2] , p[i] - ch[m-2] ) <= 0 ) m --;
        ch[m++] = p[i];
    }
    int k = m;
    for ( int i = n - 2 ; i >= 0 ; i -- )
    {
        while ( m > k && Cross ( ch[m-1] - ch[m-2] , p[i] - ch[m-2] ) <= 0 ) m-- ;
        ch[m++] = p[i];
    }
    if ( n > 1 ) m --;
    return m;
}

int main()
{
    int n,l;   
    Point cas[MAX],ch[MAX];
    scanf ( "%d %d" , &n , &l );
    for ( int i = 0 ; i < n ; i ++ )
        scanf ( "%lf %lf" , &cas[i].x , &cas[i].y );
    int cnt = ConvexHull ( cas , n , ch );
    double ans = 0;
    for ( int i = 0 ; i < cnt ; i ++ )
        ans += Distance ( ch[(i+1)%cnt] , ch[i] );
    for ( int i = 0 ; i < cnt ; i ++ )
    {
        double ang = Angle ( ch[(i+2)%cnt] - ch[(i+1)%cnt] , ch[(i+1)%cnt] - ch[i] );
        if ( dcmp ( ang ) != 0 )
        {
            ans += ang * l;
        }
    }
    if ( ans - (int)ans - 0.5 > 0 ) 
        printf ( "%d\n" , (int) ans + 1 );
    else printf ( "%d\n" , (int)ans );
    return 0;
}


技巧总结:

      凸包在计算几何中占有很重要的地位!



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
未来社区的建设背景和需分析指出,随着智能经济、大数据、人工智能、物联网、区块链、云计算等技术的发展,社区服务正朝着数字化、智能化转型。社区服务渠道由分散向统一融合转变,服务内容由通用庞杂向个性化、服务导向转变。未来社区将构建数字化生态,实现数据在线、组织在线、服务在线、产品智能和决策智能,赋能企业创新,同时注重人才培养和科研平台建设。 规划设计方面,未来社区将基于居民需,打造以服务为中心的社区管理模式。通过统一的服务平台和应用,实现服务内容的整合和优化,提供灵活多样的服务方式,如推送式、订阅式、热点式等。社区将构建数据与应用的良性循环,提高服务效率,同时注重生态优美、绿色低碳、社会和谐,以实现幸福民生和产业发展。 建设运营上,未来社区强调科学规划、以人为本,创新引领、重点突破,统筹推进、整体提升。通过实施院落+社团自治工程,转变政府职能,深化社区自治法制化、信息化,解决社区治理中的重点问题。目标是培养有活力的社会组织,提高社区居民参与度和满意度,实现社区治理服务的制度机制创新。 未来社区的数字化解决方案包括信息发布系统、服务系统和管理系统。信息发布系统涵盖公共服务类和社会化服务类信息,提供政策宣传、家政服务、健康医疗咨询等功能。服务系统功能需包括办事指南、公共服务、社区工作参与互动等,旨在提高社区服务能力。管理系统功能需则涉及院落管理、社团管理、社工队伍管理等,以实现社区治理的现代化。 最后,未来社区建设注重整合政府、社会组织、企业等多方资源,以提高社区服务的效率和质量。通过建立社区管理服务综合信息平台,提供社区公共服务、社区社会组织管理服务和社区便民服务,实现管理精简、高效、透明,服务快速、便捷。同时,通过培育和发展社区协会、社团等组织,激发社会化组织活力,为居民提供综合性的咨询和服务,促进社区的和谐发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值