HDU1069-dp水题

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19134    Accepted Submission(s): 10181


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
 
 
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
 
 
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28
Case 4: maximum height = 342

题意:输入一个n,表示有n个长方体,每个长方体无限多。问最高可以堆多高,条件是长和宽都比下面的小

思路:其实每个长方体就只能摆出6种姿势,数据是30,30*6没多大,对数据排序,然后用LIS就可以了

坑点:好像不可以用nlogn的算法,因为那个可能会改变上升子序列的数据,答案可能会错(个人认为...我也没试过)

状态转移方程:

 
for (i=2;i<j;i++)
                {
                    dp[i]=num[i].h;        //dp[i]表示第i个长方体为最上面那个
                    for (k=i-1;k>=1;k--)
                        if (num[k].l>num[i].l&&num[k].w>num[i].w)
                            dp[i]=max(dp[i],dp[k]+num[i].h);    //如果有长和宽都比num[i]大的,放在num[i]的下面,dp[i]更新
                }

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200;
int dp[maxn];
struct node
{
    int l,w,h;
}num[maxn],array[maxn];
bool cmp(const node &a,const node &b)
{
    if (a.l>b.l)
        return true;
    return false;
}
int main()
{
    int n,i,j,k;
    node m,t;
    int s=1;
    while (cin>>n&&n)
        {
            j=1;
            memset(num,0,sizeof(num));
            for (i=1;i<=n;i++)
                {
                    cin>>t.l>>t.w>>t.h;
                    num[j++]=t;
                    m.l=t.l;m.w=t.h;m.h=t.w;
                    num[j++]=m;
                    m.l=t.w;m.w=t.l;m.h=t.h;
                    num[j++]=m;
                    m.l=t.w;m.w=t.h;m.h=t.l;
                    num[j++]=m;
                    m.l=t.h;m.w=t.l;m.h=t.w;
                    num[j++]=m;
                    m.l=t.h;m.w=t.w;m.h=t.l;
                    num[j++]=m;
                }
            sort(num+1,num+j,cmp);            //把长宽大的排序到前面
            memset(dp,0,sizeof(dp));
    /*        for (i=1;i<j;i++)
                cout<<num[i].l<<" "<<num[i].w<<" "<<num[i].h<<endl;*/
            for (i=2;i<j;i++)
                {
                    dp[i]=num[i].h;
                    for (k=i-1;k>=1;k--)
                        if (num[k].l>num[i].l&&num[k].w>num[i].w)
                            dp[i]=max(dp[i],dp[k]+num[i].h);
                }
            int ans=0;
            for (i=1;i<j;i++)        //这里找出最高
                if (dp[i]>ans)
                    ans=dp[i];
            printf("Case %d: maximum height = %d\n",s++,ans);
        }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值