(ACM)Number Sequence

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

题意

通过输入A,B,n的值,根据公式求出f(n)的值。输入三个0时,结束程序。

我的代码#

#include <stdio.h>
int Fn(int a,int b,int n);
int main()
{
	int a,b,s,n;
	while(scanf("%d %d %d",&a,&b,&n)==3)
	{
		if(a==0&&b==0&&n==0)
		{
			return 0;
		}
		else if((a>=1&&a<=1000)&&(b>=1&&b<=1000)&&(n>=1&&n<=1000000000))
		{
			if(n==1||n==2)
			{
				s=1;
			}
			else
			{
				s=Fn(a,b,n);
			}
			printf("%d\n",s);
		}
		else
		{
			return 0;
		}
	}
	return 0;
}
int Fn(int a,int b,int n)
{
	int m;
	if(n==1||n==2)
	{
		m=1;
	}
	else
	{
		m=(a*Fn(a,b,n-1)+b*Fn(a,b,n-2))%7;
	}
	return m;
}

模仿别人的代码

#include <stdio.h>  
int main()  
{  
    int a,b,n,i,k,f[53];  
    while(scanf("%d%d%d",&a,&b,&n)!=EOF)
	{  
        if(a==0&&b==0&&n==0)
		{  
            break;  
        }  
        if(n>2){  
            f[0] = f[1] = 1;
            for(i=2;i<53;i++){  
                f[i] = (a*f[i-1]+b*f[i-2])%7;  
                if(i>=4&&f[i-1]==f[2]&&f[i]==f[3])
				{
                    k = i - 3;  
                    break;  
                }  
            }  
            printf("%d\n",f[2+((n-3)%k)]); 
        }else
		{  
            printf("1\n");
        }  
    }  
    return 0;  
}  

心得

在编写代码是,自己时候的迭代函数的调用,当数值比较小的时候,结果很快算出来,但是当给出的数据比较大时,在迭代函数使用时,导致占用太多的内存,并且需要不停的向上一级函数返回值,导致时间增加了很多,效率变低;而在学习了别人的代码后,他人通过找出数据的规律,然后通过简单的代码就计算出了结果。所以在做某一类题目的时候,我们更应该发现题目潜在的信息。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值