描述
Jessie has a magic mirror.
Every morning she will ask the mirror: ‘Mirror mirror tell me, who is the most beautiful girl in the world?’ If the mirror says her name, she will praise the mirror: ‘Good guy!’, but if the mirror says the name of another person, she will assail the mirror: ‘Dare you say that again?’
Today Jessie asks the mirror the same question above, and you are given a series of mirror’s answers. For each answer, please output Jessie’s response. You can assume that the uppercase or lowercase letters appearing anywhere in the name will have no influence on the answer. For example, ‘Jessie’ and ‘jessie’ represent the same person.
Input
The first line contains an integer T(1≤T≤100), which is the number of test cases.
Each test case contains one line with a single-word name, which contains only English letters. The length of each name is no more than 15.
Output
For each test case, output one line containing the answer.
样例输入
2
Jessie
Justin
样例输出
Good guy!
Dare you say that again?
题意
判断字符串是否等于“Jessie”,不区分大小写!
AC代码
import java.util.Scanner;
public class A {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t = sc.nextInt();
while(t-->0) {
String s =sc.next();
String m = s.toLowerCase();
if(m.equals("jessie"))
{
System.out.println("Good guy!");
}
else
{
System.out.println("Dare you say that again?");
}
}
sc.close();
}
}