hdu 1010 Tempter of the Bone 深搜+剪枝

Tempter of the Bone
                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.



Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.



Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.



Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0 

Sample Output
NO
YES 

Difficulty: DFS+奇偶剪枝

#include<cstdio>
#include<cstring>
#include<cmath>
int vis[1000][1000];
char map[1000][1000];
int flag,n,m,t,sx,sy,ex,ey;
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
int abs(int p)
{
    return p>=0?p:-p;
}
bool isover(int x,int y)
{
    if(x>=n||x<0||y>=m||y<0)
    return 1;
    return 0;
}
void dfs(int x,int y,int sum)
{
    if(flag==1)
    return;
    if(map[x][y]=='D'&&sum==t)//目标状态:步数为,坐标位置为D;
    {flag=1;
    return;}
    int mindis=abs(x-ex)+abs(y-ey);  /*当前点到终点的最短距离*/
    if(mindis>t-sum||(mindis+ t-sum )%2!=0)
        return;//奇偶剪枝
    for(int i=0;i<4;i++)//扩展方式:上下左右;
    {int nx=x+dx[i];
     int ny=y+dy[i];
    if(!vis[nx][ny]&&!isover(nx,ny)&&map[nx][ny]!='X')
    {vis[nx][ny]=1;
    dfs(nx,ny,sum+1);
    //printf("%d %d\n",nx,ny);
    vis[nx][ny]=0;
    }
}
}
int main()
{while(~scanf("%d%d%d",&n,&m,&t))
{if(n==0&&m==0&&t==0)
break;
memset(vis,0,sizeof(vis));
flag=0;
for(int i=0;i<n;i++)
{scanf("%s",map[i]);
for(int j=0;j<m;j++)
{if(map[i][j]=='S')
{
    sx=i;
    sy=j;
}
if(map[i][j]=='D')
{
    ex=i;
    ey=j;
}}}
vis[sx][sy]=1;
dfs(sx,sy,0);//初始状态:S的位置坐标,步数为0;
if(flag==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值