Number of Containers(数学)

Number of Containers


Time Limit: 1 Second Memory Limit: 32768 KB

For two integers m and k, k is said to be a container of m if k is divisible by m. Given 2 positive integers n and m (m < n), the function f(n, m) is defined to be the number of containers of m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0...

Let us define another function F(n) by the following equation:

Nowgiven a positive integer n, you are supposed to calculate the value ofF(n).

 

Input

There are multiple test cases. The first line of input contains an integerT(T<=200) indicating the number of test cases. Then Ttest cases follow.

Each test case contains a positive integer n (0 < n <=2000000000) in a single line.

Output

For each test case, output the result F(n) in a single line.

Sample Input

 

2
1
4

 

Sample Output

 

0
4




表示一开始题目都看不懂。。。

讲的是n/m的值到0之间有几个值!然后f(n)就是累加,,,啊!一直没懂;
eg:f(5, 1)=4,即5/1=5,5-1=4;
f(8, 2)=3,即8/2=4,4-1=3;
f(7, 3)=1,即7/3=2,2-1=1;
f(5, 4)=0,即5/4=1,1-1=0;


//求n/1+n/2+….+n/n-n的值


画图 可以用 横坐标表示i 从该点画一条垂直的线 这条线上的所有整数点的个数就是 n/i

那么n/1+n/2+n/3+……n/(n-2)+n/(n-1)+n/n 可以表示为i*(n/i)=n这条线

答案就是这条线与坐标轴围成的面积内的整数点的个数

画一条x=y的线与x*y=n相交 可以知道 面积关于x=y对称

我们求n/1+n/2+n/3+…… 只求到k=sqrt(n)处(1个梯形) 之后乘以2 (得到2个梯形的面积 其中有一个正方形的区域是重复的) 减去重复的区域k*k个 即可

 

 

ps:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3216

 n=x*y坐标上表示应为双曲线。画图后依然是这样。

 

#include<stdio.h>
#include<math.h>
int main()
{
int T;
long long n,sum,i,j,k;
scanf("%d",&T);
while(T--)
{
scanf("%lld",&n);
k=(long long)sqrt(n+1);
sum=0;
for(i=1;i<=k;i++)
sum+=n/i;
sum=sum*2-k*k-n;
printf("%lld\n",sum);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值