N!
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 70502 Accepted Submission(s): 20194
Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
Input
One N in one line, process to the end of file.
Output
For each N, output N! in one line.
Sample Input
1 2 3
Sample Output
1 2 6
Author
JGShining(极光炫影)
Recommend
数组开的过大造成超时
#include<stdio.h>
#include<string.h>
int main()
{
int n,i,j;
int a[50000];
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
a[0]=1;
for(i=2;i<=n;i++)
{
int s;
int c=0;
for(j=0;j<50000;j++)
{
s=i*a[j]+c;
a[j]=s%10;
c=s/10;
}
}
for(i=49999;i>=0;i--)
if(a[i]) break;
for(;i>=0;i--)
printf("%d",a[i]);
printf("\n");
}
return 0;
}