杭电2682 Tree

Tree

Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2119 Accepted Submission(s): 618


Problem Description
There are N (2<=N<=600) cities,each has a value of happiness,we consider two cities A and B whose value of happiness are VA and VB,if VA is a prime number,or VB is a prime number or (VA+VB) is a prime number,then they can be connected.What's more,the cost to connecte two cities is Min(Min(VA , VB),|VA-VB|).
Now we want to connecte all the cities together,and make the cost minimal.

Input
The first will contain a integer t,followed by t cases.
Each case begin with a integer N,then N integer Vi(0<=Vi<=1000000).

Output
If the all cities can be connected together,output the minimal cost,otherwise output "-1";

Sample Input
  
  
2 5 1 2 3 4 5 4 4 4 4 4

Sample Output
  
  
4 -1

Author
Teddy

Source

Recommend
lcy | We have carefully selected several similar problems for you: 2680 2677 2683 2678 2676 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 0x3f3f3f
int map[610][610],n,prime[1000010];
int min(int x,int y)
{
	return x<y?x:y;
}
void is_primes()
{
	memset(prime,0,sizeof(prime));
	prime[0]=prime[1]=1;
	for(int i=2;i*i<=1000000;i++)
	{
		if(prime[i]) continue;
		for(int j=i*i;j<=1000000;j+=i)
		prime[j]=1;
    }
}
void prim()
{
	int visit[610],lowcost[610];
	int i,j,next,min,sum;
	sum=0;
	memset(visit,0,sizeof(visit));
	for(i=0;i<n;i++)
	lowcost[i]=map[0][i];
	visit[0]=1;
	for(i=1;i<n;i++)
	{
		min=INF;
		for(j=0;j<n;j++)
		{
			if(!visit[j]&&min>lowcost[j])
			{
				min=lowcost[j];
				next=j;
			}
		}
			if(min==INF)
			{
				printf("-1\n");
				return ;
			}
			sum+=min;
			visit[next]=1;
			for(j=0;j<n;j++)
			if(lowcost[j]>map[next][j]&&!visit[j])
			lowcost[j]=map[next][j];
	}
	printf("%d\n",sum);
}
int main()
{
	int t,a[610],i,j;
	is_primes();
	scanf("%d",&t);
	while(t--)
	{
		memset(map,INF,sizeof(map));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		for(i=0;i<n;i++)
		for(j=0;j<n;j++)
		if(!prime[a[i]]||!prime[a[j]]||!prime[a[i]+a[j]])
		map[i][j]=map[j][i]=min(min(a[i],a[j]),abs(a[i]-a[j]));
		prim();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值