A - Train Problem I

A - Train Problem I
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2. 
 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input. 
 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output. 
 

Sample Input

     
     
3 123 321 3 123 312
 

Sample Output

     
     
Yes. in in in out out out FINISH No. FINISH

Hint

Hint  For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No."
#include<stdio.h>
#include<stack>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
int main()
{
	int k,i,u,h;
	while(scanf("%d",&k)!=EOF)
	{   int cd[11]={-1};
		char a[10],b[10];
	    stack<int> q;
	    queue<int> m;
	    queue<int> n;
        scanf("%s",a);
        scanf("%s",b);
		for(i=0;i<k;i++)
		{
			m.push(a[i]-'0');
			n.push(b[i]-'0');
		}
		u=0;h=0;
		while(1)
		{ 
			if(q.size()==0)
			{
				if(m.front()==n.front())
				{
					m.pop();
					n.pop();
					cd[u++]=0;
					cd[u++]=1;
				}
				else if(m.front()!=n.front())
				{
					q.push(m.front());
					cd[u++]=0;
					m.pop();
					
				}
			}
			else if(q.size()!=0)
			{
				if(q.top()==n.front())
				{
				     cd[u++]=1;
					q.pop();
					n.pop();
				}
			  else if(q.top()!=n.front())
				{
					q.push(m.front());
					cd[u++]=0;
			         m.pop();
				}
				
			}
		  if(m.size()==0&&q.size()!=0&&q.top()!=n.front())
			{
			     h=1;
				 break;	
			}
		   if(n.size()==0)
		     	break;
		}
		if(h==1)
		printf("No.\nFINISH\n");
		else if(h!=1)
		{   printf("Yes.\n");
			for(i=0;i<u;i++)
			{
				if(cd[i]==0)
				printf("in\n");
				else if(cd[i]==1)
				printf("out\n");
			}
			printf("FINISH\n");
		}

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure, here are the steps along with code explanations: 1. Understand the business problem: This step involves understanding the problem statement and the objective of the competition. In the case of the Kaggle Forest Cover Type Prediction competition, the objective is to predict the type of forest cover (out of 7 possible types) based on various geographical features like elevation, slope, aspect, etc. 2. Get the data: The data for this competition can be downloaded from the Kaggle website. It contains both training and testing datasets. 3. Discover and visualize insights: In this step, we perform exploratory data analysis (EDA) to gain insights into the data. This involves plotting various visualizations like histograms, scatter plots, heat maps, etc. to understand the distribution of the data and the relationships between different features. 4. Prepare data for ML algorithms: In this step, we preprocess the data to make it suitable for machine learning algorithms. This involves tasks like handling missing values, encoding categorical variables, scaling numerical features, etc. 5. Select a model and train it: In this step, we select a suitable machine learning model based on the characteristics of the data and the problem statement. We then train the model on the preprocessed data. 6. Fine tune your model: In this step, we try to improve the performance of the model by fine-tuning its hyperparameters. This involves using techniques like grid search, random search, and Bayesian optimization to find the optimal set of hyperparameters. 7. Launch, monitor and maintain your system: This step is not relevant for this competition. Here is some sample Python code for the first few steps: ```python import pandas as pd import numpy as np import matplotlib.pyplot as plt import seaborn as sns # Load the data train_df = pd.read_csv('train.csv') test_df = pd.read_csv('test.csv') # Explore the data print(train_df.head()) # Visualize the target variable sns.countplot(x='Cover_Type', data=train_df) plt.show() # Preprocess the data from sklearn.preprocessing import StandardScaler # Drop unnecessary columns train_df.drop(['Id', 'Soil_Type7', 'Soil_Type15'], axis=1, inplace=True) test_df.drop(['Id', 'Soil_Type7', 'Soil_Type15'], axis=1, inplace=True) # Split the data into features and labels X_train = train_df.drop(['Cover_Type'], axis=1) y_train = train_df['Cover_Type'] # Scale the features scaler = StandardScaler() X_train = scaler.fit_transform(X_train) ``` Note that this code is just a sample and may need to be modified based on the specific requirements of the competition and the characteristics of the data.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值