杭电1865 more is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 18668    Accepted Submission(s): 6862


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
就是给你一系列数据,这些数据如果能结合到一块就会结合成一棵树,并查集思想。问题就是求出得到的所有树中最大的一棵树有多少节点。
注意要求的节点数比较多 ,不用巧妙的方法容易超内存,但是用递归会爆栈。话不多说见代码。
#include<stdio.h>
#define max 10000100
int set[max],per[max],sum=0;
int find(int p)
{
	int t;
	int child=p;
	while(p!=set[p])
	{
		p=set[p];
	}
	while(child!=p)
	{
		t=set[child];//压缩路径 
		set[child]=p;//让树上的子节点直接与 根节点相连 
		child=t;//进行下一个节点 
	}
	return p;
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		set[fx]=fy;//连接两个节点 
		per[fy]+=per[fx];//让两棵树丄节点相加 
		if(sum<per[fy])
		{
			sum=per[fy];
		}
	}
}
int main()
{
	int country,i,a,b;
	while(scanf("%d",&country)!=EOF)
	{
		if(country==1)
		{
		printf("1\n");
		continue;
	    }
	for(i=0;i<=max;i++)
	 {
	 	set[i]=i;
	 	per[i]=1;
	 }
	 for(i=1;i<=country;i++)
	 {
	 	scanf("%d%d",&a,&b);
	 	join(a,b);//
	 }
		printf("%d\n",sum);
		sum=0;
	}
	return 0; 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值